Squeak from front end - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Squeak from front end

Smittybilt Products at Oconee Off-Road!Alloy USA Still AvailableCurrie Currectlync Steering Upgrade Kits and Currie Anti-R

Reply
Unread 07-15-2013, 09:15 AM   #1
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 569
Squeak from front end

I've developed quite an annoying squeak coming from what sounds like the front drivers side. I have recently installed JBAs arms but it seems as though the squeaking has just recently gotten bad. It does it over all small bumps but not noticeable over larger bumps (didn't notice is two tracking this weekend). It also doesn't seem to do it while I am applying the brakes. I just really hope its no the a-arm on the drivers side because it is such a PITA to get at.

Anyone have any thoughts? I'm really thinking/hoping its the brakes because they haven't been changed in forever

huntb is offline   Reply With Quote
Unread 07-15-2013, 09:22 AM   #2
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 569
I'm also going to try disconnecting the front sway bar links and do a little city driving to see if that is the issue
huntb is offline   Reply With Quote
Unread 07-15-2013, 09:35 AM   #3
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 542
Did you tighten the a-arms with the tires in the air or resting with the weight of the vehicle on the ground?
__________________
2010 Liberty KK Sport, deep water blue, weathertech in channel vent visors, weathertech digital floor mats, Detoures backbone winch mount w/smittybilt XRC 10 comp winch, rigid industries dually led lights on smittybilt fairhead mount, Rocklizard skink supersliders and Gecko safari rack, cobra cb w/48" firestick antenna, general grabber at2 245/75-16, OME heavy duty springs, OME shocks, about 3" - 3 1/2" of lift, Detoures Knucklebone spare tire and Jerry can mount, mopar skids, class 3 hitch w/7 pin wire harness, headlight covers, 4.10's and Detroit TruTracs F&R
Ted15 is offline   Reply With Quote
Unread 07-15-2013, 09:49 AM   #4
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 569
Quote:
Originally Posted by Ted15 View Post
Did you tighten the a-arms with the tires in the air or resting with the weight of the vehicle on the ground?
Passengers side - on the ground
Drivers side - in the air... but then I knew that was a bad idea so took the d*mn thing apart again, loosened the bolts some, dropped it to the ground and retightened fml that was fun
huntb is offline   Reply With Quote
Unread 07-15-2013, 10:24 AM   #5
khalilw
Registered User
2011 KK Liberty 
 
Join Date: Jan 2012
Location: Barquisimeto, Lara
Posts: 38
Check the brake pads in the front and make sure that you have the 4 clips on them.

They look similar to this:

khalilw is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.