sky slider issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 07-25-2013, 04:06 PM Thread Starter
tpabimmer
Registered User
 
Join Date: Jul 2013
Location: wesley chapel
Posts: 1
sky slider issue

yo forum ... new to all this ... so bear with me .... daughter has an '08 liberty with the sky slider ... has always worked really well ... she loved it ... UNTIL today .... issue is with it closing and locking in ... i will try my best to "describe" what i see .... there are two little "cars" that move within a track for each side .... and the "cover" seems to attach to these little "cars" that either push it open or close it .... BTW, we're talking about it opening from the FRONT of the jeep ....the little car on the PASSENGER side seems to be "stripped" .... i have detached the "cover" ... and the little "car" on the DRIVER'S side moves like a champ ... BUT, the passenger side moves sometimes ... (with some finger help) ... but won't move past a certain point when opening .... and as for closing, it is as if, when whatever actually moves the little "car" catches up with it ... it will then move ...but won't fully lock in ... apologies for the description .... but having been on a 'busa forum and a bmw forum ... i have found that SOMEONE, SOMEWHERE will pretty much understand my frustration, abd "strange" description of the issue...lol ... any help will be greatly appreciated !!!! thanks again all

tpabimmer is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-26-2013, 06:57 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
Quote:
Originally Posted by tpabimmer View Post
yo forum ... new to all this ... so bear with me .... daughter has an '08 liberty with the sky slider ... has always worked really well ... she loved it ... UNTIL today .... issue is with it closing and locking in ... i will try my best to "describe" what i see .... there are two little "cars" that move within a track for each side .... and the "cover" seems to attach to these little "cars" that either push it open or close it .... BTW, we're talking about it opening from the FRONT of the jeep ....the little car on the PASSENGER side seems to be "stripped" .... i have detached the "cover" ... and the little "car" on the DRIVER'S side moves like a champ ... BUT, the passenger side moves sometimes ... (with some finger help) ... but won't move past a certain point when opening .... and as for closing, it is as if, when whatever actually moves the little "car" catches up with it ... it will then move ...but won't fully lock in ... apologies for the description .... but having been on a 'busa forum and a bmw forum ... i have found that SOMEONE, SOMEWHERE will pretty much understand my frustration, abd "strange" description of the issue...lol ... any help will be greatly appreciated !!!! thanks again all
First of all, welcome to the forums. The sky slider can be a very expensive fix and although I have never had issues with mine, make sure that she isn't operating it at higher speeds. I know it seems inconvenient, but I never open or close mine at speeds greater than 40 MPH
huntb is offline  
post #3 of 4 Old 08-02-2013, 06:14 AM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by huntb View Post
First of all, welcome to the forums. The sky slider can be a very expensive fix and although I have never had issues with mine, make sure that she isn't operating it at higher speeds. I know it seems inconvenient, but I never open or close mine at speeds greater than 40 MPH
x2. I actually try to not use it at all if I'm driving. If there is a traffic light or stop sign approaching, that's the perfect opportunity to open or close it.
Gageraid is offline  
post #4 of 4 Old 10-11-2013, 06:18 PM
Seadoodude
Registered User
2008 KK Liberty 
 
Join Date: Jan 2013
Location: Cypress
Posts: 10
my daughter also had the liberty with sky slider. exact same issue after light use on a new replacement roof. Passenger side track cars in front and back are not gripping the screw cable. It's poorly designed and has been nothing but problems, which she doesn't need at college. Got her a Nissan and not sure if I can sell Jeep as is or try to fix it again. I know it's an expensive fix. Any advice?
Seadoodude is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome