Shudders at red lights-2011 Liberty - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Shudders at red lights-2011 Liberty

Dan's Old as Dirt Birthday Sale!GEARSHADE Pocket Tops in stock and available at ROCKRIDGE Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 02-15-2013, 06:33 PM   #16
jeepster1947
Registered User
2012 KK Liberty 
 
Join Date: Jan 2013
Location: Houston, TX
Posts: 37
Shudder

Another thought...my 2012 kk has a fuel cutoff feature during decelleration. Fuel cutoff at about 40 mph; restored around 20 mph. If your 2011 kk has this feature and maybe not cutting in properly perhaps that could cause the symptoms you're describing. Just a thought...

jeepster1947 is offline   Reply With Quote
Unread 02-15-2013, 07:34 PM   #17
0810dyna
Registered User
2008 KK Liberty 
 
Join Date: Feb 2013
Posts: 4
My 08 has been doing this since new. Drove an 04, did the same thing. I know better fuel and a long drive tends to help. Maybe try higher octane or fuel additive.
0810dyna is offline   Reply With Quote
Unread 02-15-2013, 07:36 PM   #18
swamppro
Registered User
2008 KK Liberty 
 
Join Date: Sep 2011
Location: Metairie, Louisiana
Posts: 319
My 08 has exhaust and chip and have always run 93 octane in it. Just started doing it. Gonna change out plugs and such
swamppro is offline   Reply With Quote
Unread 02-15-2013, 07:40 PM   #19
0810dyna
Registered User
2008 KK Liberty 
 
Join Date: Feb 2013
Posts: 4
Quote:
Originally Posted by swamppro View Post
My 08 has exhaust and chip and have always run 93 octane in it. Just started doing it. Gonna change out plugs and such
How many miles?
0810dyna is offline   Reply With Quote
Unread 02-15-2013, 07:57 PM   #20
swamppro
Registered User
2008 KK Liberty 
 
Join Date: Sep 2011
Location: Metairie, Louisiana
Posts: 319
54,000
swamppro is offline   Reply With Quote
Unread 02-17-2013, 08:08 AM   #21
teckn9ne
Registered User
2010 KK Liberty 
 
Join Date: Jul 2011
Location: La Monte, Missouri
Posts: 166
I had a shutter problem while idleing since bought mine 17k miles on it i changed plugs and still shuttered rpm would drop then go back up constantly then last week 38544 miles i went 2 dealer got BG fuel induction cleaning and i coulnt belive it but no more shacking/stuttering rpms dont fluctuate anymore runing few tanks gas through it then doing plug/wires and oil.So happy with the service was well worth the 80bucks
__________________
2010 Jeep Liberty Sport 4X4 Natural Green Pearl
Silverstar Headlights,Mopar Hitch,Mopar Tow Hook,Mopar Skids,Mopar Locking Lugs,Mopar Remote Start,Factory Sirius Radio,WeatherTech Digital Floor Mats,JCROffroad Stage 3 Sliders,Hankook DynaPro RF10 LT225/75/16,Diehard Platinum P1,JBA 5.5 UCA,OME HD,
teckn9ne is offline   Reply With Quote
Unread 02-18-2013, 09:43 AM   #22
Philmore
Registered User
2011 KK Liberty 
 
Join Date: Apr 2012
Posts: 15
I have been keeping half a tank of gas or more in it the last 2 weeks and I haven't noticed it lately. Seems fuel related. Maybe I'll try the fuel induction cleaning too.
Philmore is offline   Reply With Quote
Unread 02-18-2013, 09:51 AM   #23
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary, AB
Posts: 302
I'll try that as well next when I get my new wheels and tires put on. I'll also try 93 octane to see if that has any effect in the next couple weeks.

Thanks guys!
shawnicles is offline   Reply With Quote
Unread 02-18-2013, 10:04 AM   #24
Philmore
Registered User
2011 KK Liberty 
 
Join Date: Apr 2012
Posts: 15
I'll give the 93 a try as well
Philmore is offline   Reply With Quote
Unread 02-18-2013, 11:00 AM   #25
teckn9ne
Registered User
2010 KK Liberty 
 
Join Date: Jul 2011
Location: La Monte, Missouri
Posts: 166
I used the premium gas a few times be for the induction cleaning with no effect on the stuttering went back to regular unleaded but i noticed after cleaning the stuttering just stoped and just fells like it runs so much smoother.
__________________
2010 Jeep Liberty Sport 4X4 Natural Green Pearl
Silverstar Headlights,Mopar Hitch,Mopar Tow Hook,Mopar Skids,Mopar Locking Lugs,Mopar Remote Start,Factory Sirius Radio,WeatherTech Digital Floor Mats,JCROffroad Stage 3 Sliders,Hankook DynaPro RF10 LT225/75/16,Diehard Platinum P1,JBA 5.5 UCA,OME HD,
teckn9ne is offline   Reply With Quote
Unread 02-19-2013, 09:16 PM   #26
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary, AB
Posts: 302
Quote:
Originally Posted by teckn9ne View Post
I used the premium gas a few times be for the induction cleaning with no effect on the stuttering went back to regular unleaded but i noticed after cleaning the stuttering just stoped and just fells like it runs so much smoother.
Ya I called the dealership today and booked an apt for later in the week. Ill keep everyone posted.
shawnicles is offline   Reply With Quote
Unread 03-05-2013, 07:35 PM   #27
Philmore
Registered User
2011 KK Liberty 
 
Join Date: Apr 2012
Posts: 15
Quote:
Originally Posted by shawnicles View Post
Ya I called the dealership today and booked an apt for later in the week. Ill keep everyone posted.
Did the dealership tell you anything? I kept my gas tank half full for a few weeks and everything was fine. I've let it drop now and it's happening again
Philmore is offline   Reply With Quote
Unread 03-11-2013, 07:48 PM   #28
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary, AB
Posts: 302
I am just bringing it in on wednesday so ill let you know afterwards.
shawnicles is offline   Reply With Quote
Unread 07-02-2013, 08:02 PM   #29
Philmore
Registered User
2011 KK Liberty 
 
Join Date: Apr 2012
Posts: 15
I know this is an old thread but I see a lot of people viewing it. I did notice 3 things that made it stop.
1. Better oil (no cheap stuff)
2. Higher grade fuel occasionally
3. It never happened with more than a half tank of gas, only when half full or less
Philmore is offline   Reply With Quote
Unread 07-02-2013, 09:53 PM   #30
BenHoleton
Registered User
2008 KK Liberty 
 
Join Date: Dec 2011
Location: Franklin, TN
Posts: 468
If it only happens when the gas tank is user half full, I'd look at your fuel pump
BenHoleton is online now   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.