Red Fluid - is it power steering or transmission - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Red Fluid - is it power steering or transmission

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineWe have Engo 10k Synthetic IN STOCK!!! Hurry while supplieJeep speedometer gears at rockridge4wd

Reply
Unread 12-03-2013, 11:25 AM   #1
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary, AB
Posts: 302
Red Fluid - is it power steering or transmission

I was out on the weekend wheeling and I could hear some whining when I was turning my wheel. Also when I was at a complete stop I could barely turn it at all which led me to believe something with the power steering was acting up. Now a couple days later I can turn my wheel when at a complete stop without much issue but the 'whining' is still there when I do so.

In addition, last week I also took it to the dealership to get a new tranny filter and fluids so it could also be that leaking with that ATF4 stuff you put in it.

Anyway, those are hopefully the only options this could be. Here is what I was thinking it was. Wheeling so hard and doing donuts in the snow I over worked my power steering and the fluid (redish) was overflow or something because it was hot and expanded sortof. Or this fluid is because my transmission is leaking after service.

What do you think it is?

Redish, has a weird smell to it, not like burnt but not like oil.

shawnicles is offline   Reply With Quote Quick reply to this message
Unread 12-03-2013, 04:16 PM   #2
LKWJEEPER
Registered User
2009 KK Liberty 
 
Join Date: Nov 2012
Location: Clover, South Carolina
Posts: 1,043
I believe they are both red.. Have you noticed and leaks when stopped for a period of time?

You could always go back to the dealer and play dumb and tell them what you saw. Any good dealer would check their work or at least to see if anything is leaking.


Sent from AutoGuide.com Free App
LKWJEEPER is offline   Reply With Quote Quick reply to this message
Unread 12-04-2013, 01:11 PM   #3
jrich58
Registered User
2008 KK Liberty 
 
Join Date: May 2013
Location: Plattsburgh, NY
Posts: 78
they both use the same fluid, PS uses the ATF4 tranny fluid...def sounds like a leak of PS somewhere, with the whining at all...have you checked the fluid level for the PS?
jrich58 is offline   Reply With Quote Quick reply to this message
Unread 12-04-2013, 01:28 PM   #4
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary, AB
Posts: 302
Quote:
Originally Posted by jrich58 View Post
they both use the same fluid, PS uses the ATF4 tranny fluid...def sounds like a leak of PS somewhere, with the whining at all...have you checked the fluid level for the PS?
Its at the dealership now to see what is going on. The levels were fine though when I looked Sunday and now its stopped leaking which was the reason I though it was leaking because it overflowed somehow. But even last night its whining still at a full lock turn and then I smell something burning. Haha

I have a couple more months of warranty left! Ill replace everything befoore then! Haha
shawnicles is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 03:22 AM   #5
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 567
It could be your steering rack. They improved it in 2010 I think and I'm pretty sure there was a TSB for it. I remember someone had it break off while wheeling and had to secure it with a ratchet strap to get it off the trail.
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 07:41 AM   #6
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,383
Quote:
Originally Posted by Ted15 View Post
It could be your steering rack. They improved it in 2010 I think and I'm pretty sure there was a TSB for it. I remember someone had it break off while wheeling and had to secure it with a ratchet strap to get it off the trail.
Not sure if there is a TSB for it, but I believe about 3 members with 2008's and maybe another member with a different year have had them fail.
__________________
OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 09:17 AM   #7
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 567
It may've just been an improvement to the replacement part. It's been a while sing it was posted.
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 12-05-2013, 06:11 PM   #8
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary, AB
Posts: 302
Yeah it turned out to be just my power steering pump I believe, well at least that's what they say. I'll mention about the steering rack
shawnicles is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.