Rear Wiper takes 30 seconds to 1 minute to turn off - JeepForum.com

 
LinkBack Thread Tools
post #1 of 15 Old 05-28-2013, 03:32 PM Thread Starter
Dioxide
Registered User
 
Dioxide's Avatar
2010 KK Liberty 
 
Join Date: Mar 2003
Location: Glassboro New Jersey
Posts: 106
Rear Wiper takes 30 seconds to 1 minute to turn off

Ok so I have a new to me 2010 and everytime I go to clean or even run the rear wiper it turns on I turn it off and it continues to move on the rear window for at least 30 seconds. I am thinking its the lever on the console but has anyone run into this issue before?

Thanks in advance.


Dave
_____________________
2010 KK Sport
Dioxide is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 05-28-2013, 04:03 PM
Dewphy
Registered User
2009 KK Liberty 
 
Join Date: Mar 2012
Location: South Lyon
Posts: 24
This happens to me almost every time. In regards to a fix I have no idea. I have not figured out what I may need to do differently to keep it from happening or how it may be programmed. Anybody else with information on this?
Dewphy is offline  
post #3 of 15 Old 05-28-2013, 04:09 PM Thread Starter
Dioxide
Registered User
 
Dioxide's Avatar
2010 KK Liberty 
 
Join Date: Mar 2003
Location: Glassboro New Jersey
Posts: 106
Well I suppose at least im not alone. lol

Dave
_____________________
2010 KK Sport
Dioxide is offline  
post #4 of 15 Old 05-29-2013, 07:27 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
It is certainly not just you. Chrysler probably let some young engineer right out of school write the firmware for it...
huntb is offline  
post #5 of 15 Old 05-29-2013, 08:54 AM
Dewphy
Registered User
2009 KK Liberty 
 
Join Date: Mar 2012
Location: South Lyon
Posts: 24
Quote:
Originally Posted by huntb View Post
It is certainly not just you. Chrysler probably let some young engineer right out of school write the firmware for it...
My thoughts exactly. What bugs me the most about it is, while its on, the wiper only goes down to the edge of the window but if you turn it off and it continues swipe, it goes all the way down to where it seats below the window and then comes back up. This of course makes ridiculous thud noises as it hits the bottom seat over and over as well as hopping across the gap between the window and body. Plus it has to look real stupid to the person driving behind you witnessing this...
Dewphy is offline  
post #6 of 15 Old 05-29-2013, 10:09 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
I find that it will stop most of the time if you turn it back on and then off again and it won't do it if you leave the switch on for a second before flipping it back off again.
huntb is offline  
post #7 of 15 Old 05-29-2013, 03:24 PM
heiliges
Registered User
2012 KK Liberty 
 
Join Date: May 2013
Location: Jacksonville
Posts: 68
as huntb said. I just cycle the on/off switch till it takes. Have not found the exact sequence yet but I am sure there is one because it always works, eventually.
heiliges is offline  
post #8 of 15 Old 05-29-2013, 06:01 PM Thread Starter
Dioxide
Registered User
 
Dioxide's Avatar
2010 KK Liberty 
 
Join Date: Mar 2003
Location: Glassboro New Jersey
Posts: 106
Never dull I wonder if its just a simple computer upgrade type thing or Jeep just simply does not give a crap. I will try the turn on and off thing till it takes when i get a chance.

Dave
_____________________
2010 KK Sport
Dioxide is offline  
post #9 of 15 Old 05-31-2013, 02:27 PM
Sagerist
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2011
Location: Basalt
Posts: 701
Mine does the same thing and i have a feeling it has to do with the water getting in there because of that weather stripping they put in there that has a gap and allows water to flow through. Mine was fine and then only starting acting up after a couple of years, i assumed because some water got in the components and got it all wacked out...

The other annoying part is that you can't simply replace the wiper (that ive found) and the dealer has to do it. With all of the extra wipes when the glass is dry, it tore the wiper and leaves an arch in the middle of the wipe area of unwipped water....

Colorado Jeep Club Member #286
89 YJ 2.5L
OME 36R's, Bilstein 5100's, Bserk 5/8" shackles, 33x10.5 BFG's on 15x8

09 KK Sport 4X4
235/75/16 GY Slnt Armor
CB 2' Firestik
Fire/EMS Radio
Sagerist is offline  
post #10 of 15 Old 05-31-2013, 06:55 PM
fairmont1998
Registered User
2012 KK Liberty 
 
Join Date: Jul 2012
Location: Adelaide
Posts: 41
Mine does this too, except when I took it to the dealer to see...

2012 KK Cherokee Limited CRD
fairmont1998 is offline  
post #11 of 15 Old 05-31-2013, 07:02 PM
Dave_B
Registered User
2008 KK Liberty 
 
Join Date: Dec 2007
Location: mlps
Posts: 229
Go to Wal-Mart buy a 12 in blade no tools required almost as easy as putting gas on the vehicle.

Lovin' my CARBON FOOT PRINT!
Dave_B is offline  
post #12 of 15 Old 05-31-2013, 07:03 PM Thread Starter
Dioxide
Registered User
 
Dioxide's Avatar
2010 KK Liberty 
 
Join Date: Mar 2003
Location: Glassboro New Jersey
Posts: 106
I do have a warranty that I can use for it from the dealer i bought the Jeep from but it seems like a hassle if its a simple $60 part ill just buy it but so far havent been able to find anyone with a solution.

Dave
_____________________
2010 KK Sport
Dioxide is offline  
post #13 of 15 Old 06-01-2013, 12:38 PM
carlosburitica
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Location: fort lauderdale
Posts: 173
the rear wiper switch is all in-one. when you turn it all the way to spray windshield wash the system is set to turn the wipers on one or two times, 30 second delay and one more time to clear any water left. so when you turn the switch off the system does not recognize if you were spraying wash or operating the wiper blades.

this glitch happens in a lot of cars from Chrysler. eve in the front blades. tunr the front wipers on and pres the spray bottom, turn them off inmedialty and you still see a delay and the wipers will worm one more time after few seconds.

completely normal
carlosburitica is offline  
post #14 of 15 Old 06-04-2013, 05:12 AM
fairmont1998
Registered User
2012 KK Liberty 
 
Join Date: Jul 2012
Location: Adelaide
Posts: 41
Nah, this isn't normal operation.
When the wiper is working normally it stays on the glass, even while waiting between wipes then parks on the tailgate when it is required to do so.
It can go from the wait to park positions without performing a wipe too.

When the fault shows up the wiper travels the full distance numerous times and you can hear it crashing into the stopper each wipe until it sorts itself out.

2012 KK Cherokee Limited CRD
fairmont1998 is offline  
post #15 of 15 Old 06-04-2013, 07:57 AM
Dewphy
Registered User
2009 KK Liberty 
 
Join Date: Mar 2012
Location: South Lyon
Posts: 24
Quote:
Originally Posted by fairmont1998 View Post
Nah, this isn't normal operation.
When the wiper is working normally it stays on the glass, even while waiting between wipes then parks on the tailgate when it is required to do so.
It can go from the wait to park positions without performing a wipe too.

When the fault shows up the wiper travels the full distance numerous times and you can hear it crashing into the stopper each wipe until it sorts itself out.
Just like I said previously. This is definitely far from normal.
Dewphy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome