Rear Door Latch problems - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 03-24-2013, 06:03 PM Thread Starter
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary
Posts: 307
Rear Door Latch problems

So the last couple days I have had an issue with my rear door latch. Eventhough it is fully closed, it is alarming that it is still open. Because of this, my remote start won't work and the dome lights will constantly stay on.

I brought it to the dealer and they said it was a known problem and I will have to replace the latch and with parts and install it will be about $250 bucks.

Anyone else have this issue?

shawnicles is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-05-2013, 05:18 PM
Kracer
Registered User
 
Join Date: Apr 2013
Location: Fulton
Posts: 1
Yup same issue here. The wife's Liberty has had the Rear latch circuits replaced 3 times. This time the story is that is a bad rear seal causing water to get in and corrode the circuit and it fails. Make sure the seal is not the issue.
Kracer is offline  
post #3 of 5 Old 04-09-2013, 06:11 PM
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron
Posts: 578
Me too. It turned out to be the rear glass leaking and getting the gate or glass switch wet (can't remember which one) and causing the same issue. My alarm would even trip in the middle of the night. I had to leave it unlocked till I got it fixed. There is a TSB for that. They replace the flipper glass seal and install another rubber piece across the top of the glass on the inside. There's a whole write up over on lost about it.
If all they're willing to do is replace the switch, tell them they need to replace the window seal and install the other piece.

2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline  
post #4 of 5 Old 04-09-2013, 07:14 PM Thread Starter
shawnicles
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Calgary
Posts: 307
Quote:
Originally Posted by Ted15 View Post
Me too. It turned out to be the rear glass leaking and getting the gate or glass switch wet (can't remember which one) and causing the same issue. My alarm would even trip in the middle of the night. I had to leave it unlocked till I got it fixed. There is a TSB for that. They replace the flipper glass seal and install another rubber piece across the top of the glass on the inside. There's a whole write up over on lost about it.
If all they're willing to do is replace the switch, tell them they need to replace the window seal and install the other piece.
Thanks for that I had no idea why my alarm was going off for no reason. Ill speak with my dealer.
shawnicles is offline  
post #5 of 5 Old 04-09-2013, 08:06 PM
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron
Posts: 578
If you leave it unlocked it shouldn't wake you in the middle of the night lol

2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome