Question regarding TPMS (Tire Pressure Monitoring System) - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Question regarding TPMS (Tire Pressure Monitoring System)

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line~Artec JK 1 TON SWAP~Advance Adapters SYE Kits

Reply
Unread 10-12-2014, 03:30 PM   #1
gt5oh
Registered User
 
Join Date: Jun 2011
Location: Queens, NY
Posts: 75
Question regarding TPMS (Tire Pressure Monitoring System)

As I was driving today, the ( ! ) Caution light came on.

It pointed out that there was an issue with the TPMS Sensor and as I cycled through to the air pressure I noticed that no tire had any number displayed.

It now showed every wheel as -

I shut the car off, and upon starting ti back up, the Caution light comes back on, the car chimes 4 times, and it shows TPMS Error.

Tire pressures are normal as I checked them with a gauge. Anyone know whats causing this issue? Thanks


2008 Liberty Limited about 39,000 miles on it.

gt5oh is offline   Reply With Quote Quick reply to this message
Unread 10-12-2014, 04:08 PM   #2
lfhoward
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Ann Arbor, MI
Posts: 523
Since you have a 2008, it's possible that some of your tire sensors have low or dead batteries. On my 2008, I only have 2 original TPMS sensors left, and the rest have been replaced for various reasons (dead battery, valve stem breaking).
__________________
2008 Liberty Sport 4x4 Automatic
lfhoward is online now   Reply With Quote Quick reply to this message
Unread 10-12-2014, 05:06 PM   #3
gt5oh
Registered User
 
Join Date: Jun 2011
Location: Queens, NY
Posts: 75
Interesting.. didn't realize they go bad due to battery.

But more importantly, is what happened to the car all at once while I was driving that would cause that caution to come up and all 4 to not display pressures?
gt5oh is offline   Reply With Quote Quick reply to this message
Unread 10-12-2014, 05:42 PM   #4
lfhoward
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Ann Arbor, MI
Posts: 523
That I don't know. I have the Sport version, without the EVIC. When my TPMS go off there is only a tire light, with no indication of which one might be the problem. One other thing to check would be the pressure in your spare, if you have the full sized spare. (No TPMS in the donut spare)
__________________
2008 Liberty Sport 4x4 Automatic
lfhoward is online now   Reply With Quote Quick reply to this message
Unread 10-12-2014, 06:20 PM   #5
LibertyRS
Registered User
2012 KK Liberty 
 
Join Date: Dec 2011
Location: Birmingham, MI
Posts: 287
I'd stop by discount tire. They can scan your sensors for free. That way you know which one is bad if any are.

If its solid that means there is a problem with sensor itself whether it be broken, dead battery, etc

If its blinking it just means the air pressure is at the wrong psi.

If you have any broken ones I have a few sets from changing my wheels so often. Ill give ya the homie jeep it real special.
__________________
2012 Jeep KK
Stormtrooped
ZZzz
LibertyRS is offline   Reply With Quote Quick reply to this message
Unread 10-12-2014, 06:51 PM   #6
gt5oh
Registered User
 
Join Date: Jun 2011
Location: Queens, NY
Posts: 75
Thanks for the advice I will go to the one of the auto chains who can scan the sensors thank you.
gt5oh is offline   Reply With Quote Quick reply to this message
Unread Yesterday, 03:14 PM   #7
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 566
mine's doing the same thing. NTB told me to take it to the dealer, their scanner doesn't detect what's wrong. The guy doesn't think it's related to the sensors though.
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.