Question after test drive - JeepForum.com
 
LinkBack Thread Tools
post #1 of 10 Old 10-28-2010, 11:42 AM Thread Starter
MountaineerMan
Registered User
2008 KK Liberty 
 
Join Date: Oct 2010
Location: Martinsburg
Posts: 7
Question after test drive

I was looking at a 2008 Limited Liberty and noticed a couple times at a stop when letting off the peddle the car would shudder. Wasn't sure if it was something to to with the engine or transmission. Any advise would help. Just wondering if it's something major, if so I don't want to buy the vehicle.


MountaineerMan is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 10-28-2010, 11:50 AM
Nick_Knipp
Registered User
1986 MJ Comanche 
 
Join Date: Oct 2010
Location: Warner Robins, Georgia
Posts: 1,982
i wouldnt take it

lets see what others say

"Don't curse in your profile"
-The Moderators
'86 MJ XLS 4x4 2.8L 3spd longbed buckets
'12 MK Sport 2.4L AT rescue green
Nick_Knipp is offline  
post #3 of 10 Old 10-28-2010, 11:58 AM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Theres a few TSBs for a Shutter in the 08 KK. Was it when you were accelerating then let off the peddle? do you know where the RPM was?

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #4 of 10 Old 10-28-2010, 12:25 PM Thread Starter
MountaineerMan
Registered User
2008 KK Liberty 
 
Join Date: Oct 2010
Location: Martinsburg
Posts: 7
It was when I was at a stop letting my foot off the brake. I would barely get my foot on the gas. If pushing the gas pedal at all.
MountaineerMan is offline  
post #5 of 10 Old 10-28-2010, 02:02 PM
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
mine does that too, when the drivetrain is cold. it stops doing that when it reaches designed temp levels.

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
post #6 of 10 Old 10-29-2010, 08:46 AM Thread Starter
MountaineerMan
Registered User
2008 KK Liberty 
 
Join Date: Oct 2010
Location: Martinsburg
Posts: 7
So basically it should be ok?
MountaineerMan is offline  
post #7 of 10 Old 10-29-2010, 10:26 AM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
I never had that issue when i had my KK stock so i cant really say, but mine has larger tires on it now so it will behave differently than yours.

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #8 of 10 Old 10-29-2010, 02:02 PM
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
it sure looks normal to me, i mean it only happens when drivetrain is cold and goes away soon after it warms up. im @ 27k miles already and it didnt cause any problems at all. i have all outstanding TSBs performed on my car. it still does it. it might b annoying, but not harmful

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
post #9 of 10 Old 10-30-2010, 08:27 AM
victorville11
Registered User
 
Join Date: Sep 2010
Location: victoria
Posts: 7
My 2008 Limited Does it too... Felt kinda weird at first, but I have gotten use to it.. I have 43k miles now, and no issues with the liberty, except i have had 2 power window regulators go out this year..
victorville11 is offline  
post #10 of 10 Old 10-30-2010, 09:33 AM
Destin4Failur
Registered User
2010 KK Liberty 
 
Join Date: Oct 2010
Location: Genoa City
Posts: 5
I think you should be good with that many miles and no problems.
Destin4Failur is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
standard radio vs. touch screen hard drive..? AdventurerSport KK Liberty Forum 7 12-22-2010 06:58 PM
Delayed engagement into drive RB145 KK Liberty Forum 1 07-24-2010 08:19 PM
Odd thing in 4 wheel drive bigcreekdad KK Liberty Forum 4 01-08-2010 05:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome