Problems with Auto lights and climate contral - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Problems with Auto lights and climate contral

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsJK Front Lower Adjustable Control Arms!

Reply
Unread 09-27-2013, 11:43 AM   #1
Slayers
Registered User
2008 KK Liberty 
 
Join Date: Sep 2011
Location: Dearborn Heights, MI
Posts: 24
Problems with Auto lights and climate contral

Well since I only get to drive the Jeep 1 time a week I don't often get a chance to see if things are wrong but this am I woke up to the engine light on.

It was a small leak and I reset the light but after that I noticed that the auto lights where no coming on and even thou I had the controls on hot and defrost it was still blowing cold and out of the front vents.

Has anyone else had this problem? And what was replaced when you had it fixed?

Slayers is offline   Reply With Quote
Unread 09-27-2013, 08:44 PM   #2
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,183
Quote:
Originally Posted by Slayers View Post
Well since I only get to drive the Jeep 1 time a week I don't often get a chance to see if things are wrong but this am I woke up to the engine light on.

It was a small leak and I reset the light but after that I noticed that the auto lights where no coming on and even thou I had the controls on hot and defrost it was still blowing cold and out of the front vents.

Has anyone else had this problem? And what was replaced when you had it fixed?
A small leak where?
Gageraid is offline   Reply With Quote
Unread 10-06-2013, 12:21 AM   #3
medic455
Registered User
2010 KK Liberty 
 
Join Date: Sep 2008
Location: Dale City, VA
Posts: 91
Well I have had issues off and on with my KK as well. Take out fuse 13 in the fuse box, and put it back in. Has worked 2 times on mine. Fuse was ok, but I guess maybe loose.
__________________
2010 Jeep KK Limited loaded up.
medic455 is offline   Reply With Quote
Unread 10-07-2013, 04:40 AM   #4
TJ's02TJ
Registered User
2012 KK Liberty 
 
Join Date: Nov 2005
Location: Rising Sun, MD
Posts: 75
I have the same problem with the auto lights as well. They worked great when I first got it but not at all anymore. As far as the climate control, I have experienced that same thing but only once or twice. I just turned the temp knob from hot to cold and back to hot and the air then began to get warm.
__________________
2012 KK Liberty.

Gone but not forgotten. '02 TJ 4cyl. 2" Skyjacker Spacer Lift 31" General Grabber AT 2.
TJ's02TJ is offline   Reply With Quote
Unread 10-07-2013, 11:44 AM   #5
Slayers
Registered User
2008 KK Liberty 
 
Join Date: Sep 2011
Location: Dearborn Heights, MI
Posts: 24
Quote:
Originally Posted by medic455 View Post
Well I have had issues off and on with my KK as well. Take out fuse 13 in the fuse box, and put it back in. Has worked 2 times on mine. Fuse was ok, but I guess maybe loose.
I did the same with mine reset the MIL and then pulled the fuse and now everying seems to work.
Slayers is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.