Problems at 2000-2500rpm - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 08-04-2010, 03:44 AM Thread Starter
redmario
Registered User
2010 KK Liberty 
 
Join Date: Aug 2010
Location: Italy
Posts: 23
Problems at 2000-2500rpm

Hi,
I'm from Italy and I have a new liberty kk (my2010), crd 2.8, with manual gear.

My problem appear when the engine is about 2000 to 2500 rpm (gear 4th, 5th and 6th less with 3rd)... the engine isn't flowing but little jumping. It seems flooding.

Have you the same problem? Have you a solution?

Thank you everybody.

redmario is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-04-2010, 10:46 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by redmario View Post
Hi,
I'm from Italy and I have a new liberty kk (my2010), crd 2.8, with manual gear.

My problem appear when the engine is about 2000 to 2500 rpm (gear 4th, 5th and 6th less with 3rd)... the engine isn't flowing but little jumping. It seems flooding.

Have you the same problem? Have you a solution?

Thank you everybody.
At what speed does this happen?It sounds like the engine is lugging,maybe putting it in to high of a gear to soon.
richd is offline  
post #3 of 4 Old 08-06-2010, 03:15 PM Thread Starter
redmario
Registered User
2010 KK Liberty 
 
Join Date: Aug 2010
Location: Italy
Posts: 23
At 90 Km in 4th, 100 Km in 5th and 110 Km in 6th.

The problem appears only between 2000 and 2500 rpm and with constant speed. Accelerating, when the engine goes over 2500 it's very imperceptible.

Someone says that dependes on the settings of the central unit that does not handle well the EGR valve.

It's possible?
redmario is offline  
post #4 of 4 Old 08-06-2010, 05:33 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by redmario View Post
At 90 Km in 4th, 100 Km in 5th and 110 Km in 6th.

The problem appears only between 2000 and 2500 rpm and with constant speed. Accelerating, when the engine goes over 2500 it's very imperceptible.

Someone says that dependes on the settings of the central unit that does not handle well the EGR valve.

It's possible?
You seem top be shifting it OK,This should still be under warranty,If you can tell the dealer the problem,and see what they say.They could try to reprogram the PCM and see if that helps.
richd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
SKY SLIDER leaking problems! CDigs KK Liberty Forum 74 01-24-2016 03:03 PM
MyGIG uploading problems davejlaw KK Liberty Forum 2 11-13-2010 06:59 PM
problems ? ajyadouga KK Liberty Forum 11 07-06-2010 12:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome