Problems at 2000-2500rpm - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Problems at 2000-2500rpm

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFlowmaster's Force II Axle-back exhaust system for the 201FS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 08-04-2010, 03:44 AM   #1
redmario
Registered User
2010 KK Liberty 
 
Join Date: Aug 2010
Location: Italy
Posts: 23
Problems at 2000-2500rpm

Hi,
I'm from Italy and I have a new liberty kk (my2010), crd 2.8, with manual gear.

My problem appear when the engine is about 2000 to 2500 rpm (gear 4th, 5th and 6th less with 3rd)... the engine isn't flowing but little jumping. It seems flooding.

Have you the same problem? Have you a solution?

Thank you everybody.

redmario is offline   Reply With Quote
Unread 08-04-2010, 10:46 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
Quote:
Originally Posted by redmario View Post
Hi,
I'm from Italy and I have a new liberty kk (my2010), crd 2.8, with manual gear.

My problem appear when the engine is about 2000 to 2500 rpm (gear 4th, 5th and 6th less with 3rd)... the engine isn't flowing but little jumping. It seems flooding.

Have you the same problem? Have you a solution?

Thank you everybody.
At what speed does this happen?It sounds like the engine is lugging,maybe putting it in to high of a gear to soon.
richd is offline   Reply With Quote
Unread 08-06-2010, 03:15 PM   #3
redmario
Registered User
2010 KK Liberty 
 
Join Date: Aug 2010
Location: Italy
Posts: 23
At 90 Km in 4th, 100 Km in 5th and 110 Km in 6th.

The problem appears only between 2000 and 2500 rpm and with constant speed. Accelerating, when the engine goes over 2500 it's very imperceptible.

Someone says that dependes on the settings of the central unit that does not handle well the EGR valve.

It's possible?
redmario is offline   Reply With Quote
Unread 08-06-2010, 05:33 PM   #4
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
Quote:
Originally Posted by redmario View Post
At 90 Km in 4th, 100 Km in 5th and 110 Km in 6th.

The problem appears only between 2000 and 2500 rpm and with constant speed. Accelerating, when the engine goes over 2500 it's very imperceptible.

Someone says that dependes on the settings of the central unit that does not handle well the EGR valve.

It's possible?
You seem top be shifting it OK,This should still be under warranty,If you can tell the dealer the problem,and see what they say.They could try to reprogram the PCM and see if that helps.
richd is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.