Only 'time' will tell... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Only 'time' will tell...

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-12-2014, 01:07 AM   #1
JeepLibertyKK
Registered User
2012 KK Liberty 
 
Join Date: Dec 2013
Location: Rohnert Park, CA
Posts: 50
Only 'time' will tell...

As I have posted prior, My '12 Liberty loses about 2 minutes per week on the stereo clock. It was posted that Jeep had a bulletin regarding that issue, so since my basic warranty is set to expire, I took it in. The local dealer did the 'flash' update but I guess they determined that didn't solve the problem, as they ordered some sort of radio module. Had that part installed today, which also required re-coding all the keys. Won't know for a week or so if that solves the problem, but will post to let others know if it's worth the effort.

__________________
2012 Jeep Liberty Sport 4-wheel Drive
JeepLibertyKK is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 05:14 AM   #2
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,411
Quote:
Originally Posted by JeepLibertyKK View Post
As I have posted prior, My '12 Liberty loses about 2 minutes per week on the stereo clock. It was posted that Jeep had a bulletin regarding that issue, so since my basic warranty is set to expire, I took it in. The local dealer did the 'flash' update but I guess they determined that didn't solve the problem, as they ordered some sort of radio module. Had that part installed today, which also required re-coding all the keys. Won't know for a week or so if that solves the problem, but will post to let others know if it's worth the effort.
I was under the impression that the module is what was needed to be replaced. Keep us posted in a few months lol. People laugh when you tell them about this problem.
__________________
OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 01:03 PM   #3
NAMoulton
Registered User
2010 KK Liberty 
 
Join Date: Dec 2013
Location: Harrisonburg, VA
Posts: 413
Mine does this too. I just accepted it as a little piece of character for the Jeep and irony because I actually work with timing as a job.
NAMoulton is online now   Reply With Quote Quick reply to this message
Unread 03-12-2014, 05:53 PM   #4
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,411
Quote:
Originally Posted by NAMoulton View Post
Mine does this too. I just accepted it as a little piece of character for the Jeep and irony because I actually work with timing as a job.
Most do. I think it's model year sensitive, but most will admit there's does it. Mine does.
__________________
OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 06:36 PM   #5
LKWJEEPER
Registered User
2009 KK Liberty 
 
Join Date: Nov 2012
Location: Clover, South Carolina
Posts: 1,045
Mine did it but now I have a new stereo. This isn't a KK problem it's brand wide.

Sent from AutoGuide.com Free App
LKWJEEPER is online now   Reply With Quote Quick reply to this message
Unread 03-12-2014, 07:12 PM   #6
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst, NY
Posts: 1,207
Mine did it. Then they did the tsb and it hasn't done it since. Used to be a minute a week or so. Almost of of Chrysler does/did it.
__________________
2011 Deep Cherry Red KK - Skyslider - OME 927/731 - Bilstein Shocks - 1/4" Spacer Plate - 3/8" Clevis - Al's A-arms - 245/75-16 Duratracs
Bmxer524 is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 09:20 PM   #7
llm317
Registered User
2011 KK Liberty 
 
Join Date: Dec 2010
Location: Upper Chichester, PA
Posts: 78
Mine does it, which is inconvenient for someone who's habitually late. I set it 15 mins ahead, but in 2 weeks it was 5 mins behind. I just ignore it now.
llm317 is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 11:05 PM   #8
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,411
Quote:
Originally Posted by llm317 View Post
Mine does it, which is inconvenient for someone who's habitually late. I set it 15 mins ahead, but in 2 weeks it was 5 mins behind. I just ignore it now.
While driving I ask my girlfriend what time it is cuz I don't trust the clock.
__________________
OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 11:10 PM   #9
Rob K
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2007
Location: River Falls, Wisconsin
Posts: 1,222
I told the dealership about mine when I was in for the active head restraint recall and they didn't seem to care. Maybe they were waiting for me to make a big deal about it, which I didn't. So they didn't fix it.
Rob K is offline   Reply With Quote Quick reply to this message
Unread 03-12-2014, 11:14 PM   #10
Rob K
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2007
Location: River Falls, Wisconsin
Posts: 1,222
Quote:
Originally Posted by JeepLibertyKK View Post
As I have posted prior, My '12 Liberty loses about 2 minutes per week on the stereo clock. It was posted that Jeep had a bulletin regarding that issue, so since my basic warranty is set to expire, I took it in. The local dealer did the 'flash' update but I guess they determined that didn't solve the problem, as they ordered some sort of radio module. Had that part installed today, which also required re-coding all the keys. Won't know for a week or so if that solves the problem, but will post to let others know if it's worth the effort.
Re-coding all the keys? Does that mean if I have the clock problem fixed my plain old chipped keys that I programmed in the ignition will not work afterward? I think they can only be programmed once. Not sure about the fob keys.
Rob K is offline   Reply With Quote Quick reply to this message
Unread 03-13-2014, 12:24 AM   #11
JeepLibertyKK
Registered User
2012 KK Liberty 
 
Join Date: Dec 2013
Location: Rohnert Park, CA
Posts: 50
Quote:
Originally Posted by Gageraid View Post
I was under the impression that the module is what was needed to be replaced.
It's quite possible, but when I first called service, they told me to bring it in for a flash update. But they somehow knew that didn't solve the issue before I even got the vehicle back, and I was told they had to order a radio module.

I'll post in a week or so if it looks like it resolved the problem. If it doesn't, I'll just continue what I've been doing, correcting the time every two weeks and setting it a few minutes fast.
__________________
2012 Jeep Liberty Sport 4-wheel Drive
JeepLibertyKK is offline   Reply With Quote Quick reply to this message
Unread 03-13-2014, 05:30 AM   #12
Stang977
Member
2012 KK Liberty 
 
Join Date: Dec 2012
Location: White Plains, NY
Posts: 262
Here is the info on the TSB:

http://www.jeepforum.com/forum/f292/...-time-1467448/

I had it done. Required giving them my keys. Not sure if they replaced them or re-programmed them. Clock problem was solved. No further issues.
__________________
Me- 2012 KK, Latitude, Mineral Grey, "Cherokee" Moulding,
JBA Tommudd 3 1/2" Econolift
265/70R16 Nitto Terra's
Fuel Revolver 16X8
Rock Lizard Basket Rack

Her- 2011 WK2 Laredo X, Brilliant Black
Stang977 is offline   Reply With Quote Quick reply to this message
Unread 03-13-2014, 11:14 AM   #13
mrbeal
Registered User
2011 JK Wrangler 
 
Join Date: Apr 2013
Location: Norwell, MA
Posts: 82
I went to the dealer about this in my '11. Since it's a TSB and NOT a recall they said it would be $500+ to fix it as it required the radio module AND 2 new keys plus programming because I bought the Lib used and didn't know if the keys were the originals. I was VERY close to blowing my top (as I have a VERY short fuse sometimes...) but instead made a snap decision and decided to politely say no thank you and walk out. I do realize they were most likely trying to give me the shaft but the radio losing time just isn't that big of a deal to me. It would be nice if the time was accurate but it's not. It just seems the times I actually am running a little later than I should be and I look at the time on the clock just happens to be when it's been a couple of weeks since I have set the time and I'm actually later than I think I am.
mrbeal is offline   Reply With Quote Quick reply to this message
Unread 03-30-2014, 01:50 AM   #14
JeepLibertyKK
Registered User
2012 KK Liberty 
 
Join Date: Dec 2013
Location: Rohnert Park, CA
Posts: 50
Just wanted to post an update to this thread... I had the TSB done, which required a reflash and then the replacement of a radio module.

It's been a little more than two weeks since that work was done and today I checked the accuracy of the clock... perfect! No more setting the clock ahead by five minutes and it's running behind the following week. Looks like the effort was well worth it.
__________________
2012 Jeep Liberty Sport 4-wheel Drive
JeepLibertyKK is offline   Reply With Quote Quick reply to this message
Unread 03-30-2014, 10:58 PM   #15
Rob K
Registered User
1995 XJ Cherokee 
 
Join Date: Sep 2007
Location: River Falls, Wisconsin
Posts: 1,222
Quote:
Originally Posted by JeepLibertyKK View Post
Just wanted to post an update to this thread... I had the TSB done, which required a reflash and then the replacement of a radio module.

It's been a little more than two weeks since that work was done and today I checked the accuracy of the clock... perfect! No more setting the clock ahead by five minutes and it's running behind the following week. Looks like the effort was well worth it.
Did they have to do anything with your keys?
Rob K is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.