No Bus error. Need Help Fast! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > No Bus error. Need Help Fast!

ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Savvy FREE SHIPPING!Year End Clearance Sale! Save 20%

Reply
Unread 12-19-2010, 08:55 AM   #1
theonlyMcG
Registered User
2008 KK Liberty 
 
Join Date: Sep 2010
Location: Minneapolis, Minnesota
Posts: 8
No Bus error. Need Help Fast!

I have a 2008 Jeep Liberty with ~77000 miles on it. So I have been working on this last night and this morning. This might get a bit lengthy but I want to include everything I know. Last night I got off work at 5:00 pm and got out to my car and it started fine, drove it the grocery store picked up some food came out and it started fine again, no noticeable differences in the way it started. Drove it home and was in there for about 15 minutes then went back outside to drive somewhere and it was dead. The keyless entry doesnt work, the interior lights don't turn on when the door is opened, when you turn the key there is absolutely nothing from the engine but the gauge lights and a bunch of the cluster lights come on as well as all the lights down by the hazard lights button and the radio comes on. The only thing I get by the odometer is the "no bu5" error message. The lights that stay solid/don't flash when i turn the key are:
  • Check Engine
  • Electronic Throttle Control
  • Low Fuel
  • Charging System Warning
  • Oil Pressure
  • Security Red Light
  • BRAKE
  • ESP/BAS
The only one that flashes is the TPMS light. I don't really know where to start looking to diagnose this one and I am afraid that it is going to be expensive to fix. From what I understand is that the ECU or some other part of the electrical system has lost communication with the bus and that is what is throwing this error, but I don't really know where to go from there. Sorry for the long post I just wanted to include information hoping someone could help.

theonlyMcG is offline   Reply With Quote Quick reply to this message
Unread 12-19-2010, 12:59 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
This sounds like a WCM problem.I had this problem on my 08 KK.and it did the same thing,there is also a TSB for this problem.First thing to do is check the fuse for WCM,if its OK,unhook your battery for about a min.,and hope the WCM resets,if not you may need to replace the WCM.Here is the TSB:

https://docs.google.com/leaf?id=0B8C...out=list&num=5
richd is offline   Reply With Quote Quick reply to this message
Unread 12-19-2010, 05:45 PM   #3
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Quote:
Originally Posted by richd View Post
This sounds like a WCM problem.I had this problem on my 08 KK.and it did the same thing,there is also a TSB for this problem.First thing to do is check the fuse for WCM,if its OK,unhook your battery

https://docs.google.com/leaf?id=0B8C...out=list&num=5
RichD good one.. Chrysler is well aware of the liberty electrical problems and glitches.

Every oil change, I reset the WCM and ECU. This battery quick release mod was very inexpensive and comes in handy:
http://www.jeepforum.com/forum/f292/...e-mod-1120928/
__________________
2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline   Reply With Quote Quick reply to this message
Unread 12-19-2010, 07:04 PM   #4
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by SuperRliBerty View Post
RichD good one.. Chrysler is well aware of the liberty electrical problems and glitches.

Every oil change, I reset the WCM and ECU. This battery quick release mod was very inexpensive and comes in handy:
http://www.jeepforum.com/forum/f292/...e-mod-1120928/
Thanks,it seems like you know the problems.I also have a 06 Charger,and they have the same problem.The electrical system on Chrysler vehicles are a nightmare,the dealers have trouble fixing them.
richd is offline   Reply With Quote Quick reply to this message
Unread 12-20-2010, 01:37 PM   #5
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Quote:
Originally Posted by richd View Post
Thanks,it seems like you know the problems.I also have a 06 Charger,and they have the same problem.The electrical system on Chrysler vehicles are a nightmare,the dealers have trouble fixing them.

It all boils down to the on board computer and components. chrysler outsourced the electronic software for their vehicles.

Did you get the hemi on the '06 charger? was at a auto show recently and saw a 3.5L Charger with magnaflow dual exhaust and it sounded great!
__________________
2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline   Reply With Quote Quick reply to this message
Unread 12-20-2010, 04:18 PM   #6
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by SuperRliBerty View Post
It all boils down to the on board computer and components. chrysler outsourced the electronic software for their vehicles.

Did you get the hemi on the '06 charger? was at a auto show recently and saw a 3.5L Charger with magnaflow dual exhaust and it sounded great!
I have the 3.5 with Borla/Mopar dual catback system.It sounds good,plus boost performance and MPGs.A win win
richd is offline   Reply With Quote Quick reply to this message
Unread 12-20-2010, 05:23 PM   #7
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Quote:
Originally Posted by richd View Post
I have the 3.5 with Borla/Mopar dual catback system.It sounds good,plus boost performance and MPGs.A win win
Cool
__________________
2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.