New Battery? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > New Battery?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineDan's Old as Dirt Birthday Sale!GEARSHADE Pocket Tops in stock and available at ROCKRIDGE

Reply
Unread 05-04-2013, 07:10 PM   #1
evans956
Registered User
 
Join Date: May 2012
Posts: 43
New Battery?

Hey all,

My 2009 KK has been doing some weird things lately. A few times my TPMS light went on and off. Lately it has not. Also recently I have my Abs light and trac control come on and went of after restarting . Also my jeep seems to have trouble accelerating. Could this be due to a weak battery? Original equipment still installed.

evans956 is offline   Reply With Quote
Unread 05-04-2013, 07:43 PM   #2
lfhoward
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Philadelphia, PA
Posts: 447
My OE battery died on me over the winter (2008 KK), so your 2009 battery could be on its last legs too.
__________________
2008 Liberty Sport 4x4 Automatic
lfhoward is online now   Reply With Quote
Unread 05-05-2013, 02:17 AM   #3
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,274
Quote:
Originally Posted by lfhoward View Post
My OE battery died on me over the winter (2008 KK), so your 2009 battery could be on its last legs too.
x2. Mine lasted just as long.
Gageraid is offline   Reply With Quote
Unread 05-05-2013, 07:18 PM   #4
BillyP
Registered User
 
Join Date: Nov 2005
Location: Cedar Point, NC
Posts: 65
If your battery has been starting the Liberty it's not bad enough to be causing the problems you have been having.
BillyP is offline   Reply With Quote
Unread 05-05-2013, 07:26 PM   #5
evans956
Registered User
 
Join Date: May 2012
Posts: 43
Yea I had the voltage checked and the battery seems pretty good. Maybe it just needs new plugs. 82000 miles on it
evans956 is offline   Reply With Quote
Unread 05-05-2013, 08:38 PM   #6
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 7,999
Quote:
Originally Posted by evans956 View Post
Yea I had the voltage checked and the battery seems pretty good. Maybe it just needs new plugs. 82000 miles on it
You should be getting ready for the 3rd plug change due at 90k,coppers only and change every 30k.Tkaes like 20mins to chnage the plugs in a Liberty.


A bad battery can cause funky issues in a Liberty,even ones that test good but none of your issues will be caused by a bad battery.Large temp changes are why your TPMS light goes on/off.Several issues can cause the ABS/trac lights to come off/on.Worn plugs can cause your acceleration issue alnog with several other maintenance items.
__________________
'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline   Reply With Quote
Unread 05-06-2013, 05:14 AM   #7
evans956
Registered User
 
Join Date: May 2012
Posts: 43
I bought the jeep used so I don't think the plugs have been changed. Bought it with 62k on probably just needs plugs wires look good
evans956 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.