Need help wtih '08 severe electrical problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Need help wtih '08 severe electrical problem

Huge Soft top SaleAdvance Adapters SYE KitsCurrie Antirock, Currectlync & Lift Kits on Sale!

Reply
Unread 09-04-2011, 10:45 AM   #1
dlefever
Registered User
 
Join Date: Sep 2011
Location: Newtown, PA
Posts: 2
Need help wtih '08 severe electrical problem

I have onwed an '08 Liberty for four months now and I keep experiencing a recurring electrical problem. While driving, several electrical devices suddenly turn on...alarm sounds, wipers turn on, lights turn on, washer fluid starts to spit out, amber parking lights flicker and more. When the problem starts, I pull off the road and turn it off. Turning the vehicle on sometimes stops the problem and other times it continues. When the problem takes place, there is no code on the compuer to assist with troubleshooting.

There is one other electrical issue that may be connected to this same problem. My airconditioner fan will intermittently turn off and on for no apparent reason. WHen this happens, the amber parking lights tun on but they are half bright.

It could be a ground issue, but my mechanic spent several hours checking the wiring and no problems were found. If anyone has expereinced this same problem, I would be anxious to hear what was the root cause and the resolution to the problem.


Last edited by dlefever; 09-04-2011 at 10:47 AM.. Reason: spelling correction and additional detail supplied
dlefever is offline   Reply With Quote Quick reply to this message
Unread 09-05-2011, 03:26 PM   #2
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
i think there is a TSB for that, i remember few folks here having this issue. just dont remember which one was it.
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 09-05-2011, 06:40 PM   #3
dlefever
Registered User
 
Join Date: Sep 2011
Location: Newtown, PA
Posts: 2
Any idea where can I see a listing of TSB's? I have searched online and I cannot find any "easy to use" TSB reference.
dlefever is offline   Reply With Quote Quick reply to this message
Unread 09-05-2011, 06:44 PM   #4
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
http://www.jeepforum.com/forum/f292/...-list-1076433/
here are some of them, not sure if the list is up to date nor do i see the one applicable to your issue in the list. search the forums here, should b there somewhere
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 09-05-2011, 06:56 PM   #5
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
http://www.jeepforum.com/forum/f292/help-1091145/
this sounds like somewhat similar issue
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 09-05-2011, 06:57 PM   #6
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
Quote:
Originally Posted by dlefever View Post
There is one other electrical issue that may be connected to this same problem. My airconditioner fan will intermittently turn off and on for no apparent reason. WHen this happens, the amber parking lights tun on but they are half bright.
this part does sound like a bad ground, had this happen on my civic when the radiator fan would kick in
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 09-07-2011, 12:41 PM   #7
yankeebikachic
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Durham, NC
Posts: 8
Does sound like a ground. My husband looked for a bad ground on my old Jeep one time for over 8 hours...took it to the dealer and it took them almost 4...did they look for some time?
yankeebikachic is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.