My fogs just crapped out... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > My fogs just crapped out...

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRubicon Express Suspensions from CCOR 706-207-4140Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955

Reply
Unread 10-18-2013, 07:21 PM   #1
silver08kk
Registered User
2008 KK Liberty 
 
Join Date: Jul 2011
Location: Mount Sterling, KY
Posts: 137
My fogs just crapped out...

Well, walked out to get in my KK after dark...started her up...and no fogs. The odds of both bulbs burning out at the same time are highly unlikely. Not sure what the hell is going on...it's almost like this thing is falling apart day by day.
The only thing odd was earlier this afternoon I got in it and went to start it and it was like it was only half firing...and making a clicking sound. I killed it real quick, then started it back up and was fine. Well, I guess everything but the fogs.
Mine are the add-on kit, wondering if maybe I somehow "unflashed" them???

Any other suggestions???

silver08kk is offline   Reply With Quote
Unread 10-18-2013, 08:18 PM   #2
eoerikson3
Registered User
2011 KK Liberty 
 
Join Date: Dec 2011
Location: Pawtucket, Rhode Island
Posts: 360
High beams are off? That would be one reason for them to not come on.

Sent from my iPhone using JeepForum
__________________
-Oscar
Chrome may not get you home, but sometimes it looks nice.
2011 Liberty Sport
Added tow hitch, tow hooks, skid plates, foglight kit and headlight masks, remote start, chrome steps, and Cooper Discoverer A/T3 235/75R16.
[URL="http://www.jeepforum.com/forum/f128/2008-2012-liberty-kk-electrical-parts-1517747/"]Stuff for sale[/URL]
eoerikson3 is offline   Reply With Quote
Unread 10-18-2013, 08:42 PM   #3
silver08kk
Registered User
2008 KK Liberty 
 
Join Date: Jul 2011
Location: Mount Sterling, KY
Posts: 137
Quote:
Originally Posted by eoerikson3
High beams are off? That would be one reason for them to not come on. Sent from my iPhone using JeepForum
Yes, I'm not an idiot...
silver08kk is offline   Reply With Quote
Unread 10-18-2013, 08:53 PM   #4
eoerikson3
Registered User
2011 KK Liberty 
 
Join Date: Dec 2011
Location: Pawtucket, Rhode Island
Posts: 360
Quote:
Originally Posted by silver08kk
Yes, I'm not an idiot...
I didn't mean to imply that. Just that sometimes the obvious gets overlooked.

Sent from my iPhone using JeepForum
__________________
-Oscar
Chrome may not get you home, but sometimes it looks nice.
2011 Liberty Sport
Added tow hitch, tow hooks, skid plates, foglight kit and headlight masks, remote start, chrome steps, and Cooper Discoverer A/T3 235/75R16.
[URL="http://www.jeepforum.com/forum/f128/2008-2012-liberty-kk-electrical-parts-1517747/"]Stuff for sale[/URL]
eoerikson3 is offline   Reply With Quote
Unread 10-18-2013, 09:05 PM   #5
silver08kk
Registered User
2008 KK Liberty 
 
Join Date: Jul 2011
Location: Mount Sterling, KY
Posts: 137
Sorry, just pissed. Seems like I can't catch a break here lately.
I haven't pulled the bulbs out, but looked at them closely with a LED mag light, and the filaments still look good. Connections to bulbs are good, and so are the fuses.
That only leaves the stem...or the software...
silver08kk is offline   Reply With Quote
Unread 10-21-2013, 07:03 AM   #6
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 570
Check the fuse?
huntb is offline   Reply With Quote
Unread 10-21-2013, 07:46 AM   #7
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,352
Just thinking out loud, but have you tried the fogs when the Jeep is off?
Gageraid is offline   Reply With Quote
Unread 10-21-2013, 08:26 AM   #8
silver08kk
Registered User
2008 KK Liberty 
 
Join Date: Jul 2011
Location: Mount Sterling, KY
Posts: 137
Checked the fuse and tried when it's off also.
silver08kk is offline   Reply With Quote
Unread 10-21-2013, 10:01 AM   #9
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 570
Does the light in the cluster come on when you try to turn them on?
huntb is offline   Reply With Quote
Unread 10-21-2013, 10:52 AM   #10
silver08kk
Registered User
2008 KK Liberty 
 
Join Date: Jul 2011
Location: Mount Sterling, KY
Posts: 137
Yeah, it's coming on Everytime.
silver08kk is offline   Reply With Quote
Unread 10-21-2013, 11:00 AM   #11
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,352
Fogs are pretty cheap if you just want to buy some new ones to try them out real quick in case they both did crap out at the same time.
Gageraid is offline   Reply With Quote
Unread 10-21-2013, 12:06 PM   #12
silver08kk
Registered User
2008 KK Liberty 
 
Join Date: Jul 2011
Location: Mount Sterling, KY
Posts: 137
Mine aren't. I run PIAA bulbs...and I have to order a set since no one carries them around me. Usually around $60 a pair.
silver08kk is offline   Reply With Quote
Unread 10-21-2013, 12:28 PM   #13
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 570
You can take a volt meter and try measuring potential across the contacts on the fogs when on to see if they are getting voltage. Other than that you don't sound like you're very much help for yourself and might as well take it to a shop
huntb is offline   Reply With Quote
Unread 10-22-2013, 12:08 PM   #14
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,352
Quote:
Originally Posted by silver08kk View Post
Mine aren't. I run PIAA bulbs...and I have to order a set since no one carries them around me. Usually around $60 a pair.
I'm running Putco. $30 for a pair I believe.
Gageraid is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.