Liberty KK 08 tranny problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 05-20-2011, 01:29 PM Thread Starter
Miguelacho
Registered User
2008 KK Liberty 
 
Join Date: May 2011
Location: Lecheria
Posts: 2
Liberty KK 08 tranny problem

After a long drive, 300 miles, and after resting overnight, I started my truck normally, and when set to D, she moved roughly like doing small jumps. I hauled her to the dealer and said that a need to replace the automatic transmission, it is 4x4. After a brief discussion, I drove her again along with the dealer tech, and rode smooth without any noise or jump. After driving through a climbing road, going downhiil, I felt a bang in the transmission, and again to the dealer, no code in the scanner and no lights in the panel. The dealer tech response was the same as before, need a new tranny. Any comments? The truck has 25 K.

Miguelacho is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-20-2011, 01:37 PM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
First off, Welcome!! There are several TSBs in the TSB section that may help with the transmission shudder. Bring these up to the dealer as im sure they have heard of this problem.

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #3 of 4 Old 05-20-2011, 04:29 PM Thread Starter
Miguelacho
Registered User
2008 KK Liberty 
 
Join Date: May 2011
Location: Lecheria
Posts: 2
Liberty KK 08 tranny problem

Thanks for the info. I have downloaded 3 TSBs related to lib transmission shrudder and hope to get the problem solved at dealer shop.
Miguelacho is offline  
post #4 of 4 Old 05-20-2011, 07:44 PM
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
if you are talking about it driving in lil jerks while engine is cold and when you slighlty press the brake pedal while gas pedal is depressed then its normal

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Liberty 2008 - rubber around the shaft - problem langus KK Liberty Forum 5 10-22-2013 09:52 PM
What Liberty to get? wwessels KK Liberty Forum 10 05-01-2011 07:40 PM
Getting rid of my liberty... JFD140 KK Liberty Forum 2 12-09-2010 04:06 AM
5W-40 on Liberty KK 3.7 nkanakakis KK Liberty Forum 6 11-02-2010 01:35 PM
Should I get a Liberty? kinsale KK Liberty Forum 13 10-31-2010 05:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome