Just put 12k miles on royal purple - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 07-03-2013, 03:56 PM Thread Starter
Cobradwight
Registered User
2012 KK Liberty 
 
Join Date: Jun 2013
Location: Victorville
Posts: 71
Just put 12k miles on royal purple

I switched to royal purple at 7500 miles , 6 months ago. I just hit 19500 and will change the oil tomorrow . I'm gonna send a sample to blackstone lab once my kit comes in . So hopefully I should have a report in a few weeks.

Cobradwight is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-04-2013, 01:32 PM Thread Starter
Cobradwight
Registered User
2012 KK Liberty 
 
Join Date: Jun 2013
Location: Victorville
Posts: 71
Changed the oil today with more royal purple and Mobil 1 filter. One thing I rec is checking your oil filter is tight ever so often. Mine was so loose I twisted it by hand and it came loose with ease. Only thing I can think of is engine vibration because I put it on pretty tight the last time. It wasn't leaking so I got extremely lucky.
Cobradwight is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome