Jeep Liberty KK 2009 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 7 Old 05-14-2011, 09:52 AM Thread Starter
LibertyJ
Registered User
2014 WK 
 
Join Date: May 2011
Location: Winnipeg
Posts: 20
Jeep Liberty KK 2009

Hi all, just signed up and looks like a real good site of info for us Jeep owners.

I have 29000kms on mine and am having to add 1/4 to 1/2 litre to top off the oil, approx. 1x month. Dealer informed to come in and have it topped off. If I do so for a third time, Chrysler Canada will be contacted. Dealer said a tear down may need to happen.

Anyone else with this problem? Is it possible the engine has not broken in yet?

Feedback appreciated!

Cheers

LibertyJ is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-14-2011, 01:14 PM
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 3,006
First post - welcome to JF

Please fill out your KK's profile.

Moving your post to the KK section.

05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded - Sold 2015
95BadBoy is offline  
post #3 of 7 Old 05-14-2011, 04:08 PM
MtnLuvr
Registered User
2009 KK Liberty 
 
Join Date: Jan 2009
Location: Kansas City Area
Posts: 103
Quote:
Originally Posted by LibertyJ View Post
Hi all, just signed up and looks like a real good site of info for us Jeep owners.

I have 29000kms on mine and am having to add 1/4 to 1/2 litre to top off the oil, approx. 1x month. Dealer informed to come in and have it topped off. If I do so for a third time, Chrysler Canada will be contacted. Dealer said a tear down may need to happen.

Anyone else with this problem? Is it possible the engine has not broken in yet?

Feedback appreciated!

Cheers
Not heard of this. Hmmmmm.

Welcome to the forum though.

2009 KK Limited 4x4
Jeep Green/partially dechromed/Sunroof/OEM Skids/
Gray Leather/uConnect GPS-Nav/DVD Head Rests/

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
/JBA 4" AaS Lift w/UCAs/16x8's w/ 245/75R16 GY MT/Rs
MtnLuvr is offline  
post #4 of 7 Old 05-15-2011, 08:46 AM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
Welcome and this is the first time I've heard of this problem.

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #5 of 7 Old 05-17-2011, 11:09 AM
beherenow
Registered User
2009 KK Liberty 
 
Join Date: Jul 2009
Location: Mty Mexico
Posts: 97
Quote:
Originally Posted by LibertyJ View Post
Hi all, just signed up and looks like a real good site of info for us Jeep owners.

I have 29000kms on mine and am having to add 1/4 to 1/2 litre to top off the oil, approx. 1x month. Dealer informed to come in and have it topped off. If I do so for a third time, Chrysler Canada will be contacted. Dealer said a tear down may need to happen.

Anyone else with this problem? Is it possible the engine has not broken in yet?

Feedback appreciated!

Cheers

mine is '09 as well and i'm about at the same rate of 29 - 30k kms...
i'm not sharing that problem tho... good luck!
beherenow is offline  
post #6 of 7 Old 05-26-2011, 09:08 PM Thread Starter
LibertyJ
Registered User
2014 WK 
 
Join Date: May 2011
Location: Winnipeg
Posts: 20
Quote:
Originally Posted by beherenow View Post
mine is '09 as well and i'm about at the same rate of 29 - 30k kms...
i'm not sharing that problem tho... good luck!
Thanx. So far so good. Not losing any more oil. Maybe finally broken in?
LibertyJ is offline  
post #7 of 7 Old 05-27-2011, 09:02 AM
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
knock on wood i have 33k miles and the bottom is as dry as it was new. your problem is def one of a kind with KK, prolly a QA problem at the factory

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Removing shift knob on 2009 Jeep Liberty sbunney KJ Liberty Forum 4 03-26-2011 12:17 AM
2009 Jeep Liberty Fog Lights 09kk KJ Liberty Forum 3 09-13-2009 06:25 PM
what is our opinion about jeep liberty 2009 sport 4x2 edgaremb KJ Liberty Forum 9 07-04-2009 01:52 PM
Jeep Liberty wins 2009 Vechicle Owner Satisfaction Award for mid-size SUV jackbooty KJ Liberty Forum 5 05-24-2009 06:42 AM
2009 Jeep Liberty Early Build? spolebitski KJ Liberty Forum 0 11-26-2008 11:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome