Issues after installing lift this weekend - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Issues after installing lift this weekend

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 03-10-2014, 08:08 AM   #1
rangerr47
Registered User
2012 KK Liberty 
 
Join Date: Aug 2011
Location: Dallas, Tx
Posts: 157
Issues after installing lift this weekend

I installed my OME lift, but I have a couple questions...

First, the rear springs are not the same size on both ends like the fronts and like the rear factory springs, one end is more open, so it does not look right sitting on the ISO, like it will contact metal on both sides...

Next everything else seems fine, but there is a clanking or knock on the rear passenger side while driving, does not have to be a big bump, but you can hear it as you drive. I redid the sway bar thinking it was just not tight or right, but still hear the sound. I do not see anything out of sorts. What else can it be?

rangerr47 is offline   Reply With Quote Quick reply to this message
Unread 03-10-2014, 09:42 AM   #2
LKWJEEPER
Registered User
2009 KK Liberty 
 
Join Date: Nov 2012
Location: Clover, South Carolina
Posts: 1,039
I've got the same issue on mine. Any bump I go over I'll hear it. I'll need to get this checked out.

Sent from AutoGuide.com Free App
LKWJEEPER is offline   Reply With Quote Quick reply to this message
Unread 03-10-2014, 09:49 AM   #3
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 578
Possibly play between shock and shock mounts remedied by stuffing a couple washers in there or in my case, I believe that now because the ride is more harsh, my plastic bumper cover shakes and hits making noise. When it gets warmer out I'm going to stuff some foam tape up in there
huntb is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.