Instrument warning lights - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Instrument warning lights

The NEW Revolution Gear and Axle from 4LowParts.comTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 03-27-2013, 04:35 PM   #1
polecat123
Registered User
2014 WK 
 
Join Date: Oct 2012
Location: Bellevue, NE
Posts: 9
Instrument warning lights

I was driving home today and a chiming tone came on and the instrument lights all light up. Once this was over the traction control, ABS, ESP, Serv 4x4 lights stayed on. The serv 4x4 light has come on before but always goes away after turning the jeep off for a minute. The same thing happened today when I turned off the jeep.

So what should I look for as an issue besides the obvious fusses.

BTW - Jeep Info 2010 KK 4x4 w/ 37.5k miles.

TIA

polecat123 is offline   Reply With Quote
Unread 03-27-2013, 06:12 PM   #2
rescue575
Senior Member
 
rescue575's Avatar
2011 KK Liberty 
 
Join Date: Feb 2012
Location: Franklin Square, NY
Posts: 912
Quote:
Originally Posted by polecat123 View Post
I was driving home today and a chiming tone came on and the instrument lights all light up. Once this was over the traction control, ABS, ESP, Serv 4x4 lights stayed on. The serv 4x4 light has come on before but always goes away after turning the jeep off for a minute. The same thing happened today when I turned off the jeep.

So what should I look for as an issue besides the obvious fusses.

BTW - Jeep Info 2010 KK 4x4 w/ 37.5k miles.

TIA

I had a very similar issue with my '07 grand Cherokee. Had several occasions when that happened then would correct itself after a while. Finally when I was driving at night in PA, happened again, then everything just shut off. Only electrical components that were functioning where headlights and tail lights thank god considering it was midnite.

Got it home, ran it up to dealership next morning. They told me, and if I'm remembering correctly, the ignition control module went. Told me he was surprised the engine didn't cut off while I was driving.
__________________
2011 Liberty Sport
2 KC Slimlite[RIGHT] 130 Watt Long Range on JK Bar
TMS Aluminum Roof Rack Cross Bars
Cobra 75, Firestik Door Jam Mount, HD Spring, 2Ft Firestik
Dunlop Fierce Attitude M/T
rescue575 is offline   Reply With Quote
Unread 03-29-2013, 10:12 AM   #3
Poncherello
Moderator
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Paterson, New Jersey
Posts: 973
Another thing you could do is disconnect the positive battery cable for about a minute - maybe give your Lib a kind of reset. If the same thing happens again I would take it to the "stealer" let them evaluate and then take it to a trusted mechanic and have him/her make the repair.
__________________
When you get knee-deep in a situation, floor it.
Poncherello is offline   Reply With Quote
Unread 04-05-2013, 02:32 PM   #4
polecat123
Registered User
2014 WK 
 
Join Date: Oct 2012
Location: Bellevue, NE
Posts: 9
Found to be a bad ABS speed sensor and damaged wiring harness to this sensor. Replaced both and all is well in the world again.
polecat123 is offline   Reply With Quote
Unread 04-05-2013, 04:05 PM   #5
BillyP
Registered User
 
Join Date: Nov 2005
Location: Cedar Point, NC
Posts: 65
Thanks for posting up the outcome.
BillyP is offline   Reply With Quote
Unread 04-05-2013, 04:18 PM   #6
polecat123
Registered User
2014 WK 
 
Join Date: Oct 2012
Location: Bellevue, NE
Posts: 9
Strange that the wiring harness was damaged also. The heat shield that is above the cat was torn and that had to be replaced earlier in 2012. Don't remember running over anything but something tore up the bottom of my Jeep.
polecat123 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.