Instrument panel warning light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Instrument panel warning light

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineOld Man Emu WK Lift - Black Friday Special!!The Original 3/8" Ruffstuff Diff Cover!

Reply
Unread 02-04-2011, 03:31 PM   #1
11davie
Registered User
 
Join Date: Feb 2011
Location: Vancouver, wa
Posts: 3
Instrument panel warning light

I have done some searching on this problem, but have not come up with much other then the advice of taking it into the dealer, which has been done twice now with nothing done. My wife has a company vehicle that is a 2008 Liberty. She drive a lot, often more than 300 miles in one day, so I am concerned that this issue could leave her stranded or worse. What happened is that her instrument panel warning lights will turn on: the ESP OFF in the odometer area, the 4WD and SRV 4WD. They donít always come on at the same time and sometimes they alternate between each other. I think the most common sequence is that it will display ESP OFF then the 4WD and SRV 4WD, then they might turn off and the 4LOW will come on and the N light on the 4x4 selector switch will turn on. Sometimes they all turn off, or sometimes they will all stay on. When she has taken it to the dealer they say they are not able to reproduce the issue, she usually needs to be driving for 20 minutes or more to get to happen, though just the other day it did immediately.

I found this thread that talks about something similar on the Patriot forum, so I thought I would look into this, but I donít know how similar these vehicles are ďunder the hoodĒ, and even though this is a company vehicle, I donít want my wife stranded 150 miles from home. http://www.***********.com/forum/showthread.php?t=17723

Also tire pressure light is always on, even though I personally have verified that they pressure is fine. This seems to be a common issue though.

Has anyone experienced this, and if so how was it fixed for you?

Thank you!

11davie is offline   Reply With Quote Quick reply to this message
Unread 02-05-2011, 04:34 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Your flashing 4x4 light sounds like a shorted out selector switch on the tranfer case,or wiring harness problem.Your TPMS light sounds like a bad WCM.
richd is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.