I might be crazy, but..... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > I might be crazy, but.....

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! SPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!Yukon Ultimate 35 axle kit for c/clip axles with Yukon Zip

Reply
Unread 03-17-2014, 12:16 PM   #1
CreepMSU
Registered User
 
Join Date: Mar 2014
Location: Redford, Michigan
Posts: 2
I might be crazy, but.....

Hey Folks,

I have a 2011 Liberty with about 50,000 miles.

Now, before I start, I would like to say that I honestly don't know if it has always done this or if it should do this. This morning, I went to warm it up. I put the heat all the way up and put the control dial on defrost as per normal. When i was driving to work, I switched the control knob to the floor vents only setting and noticed that air was still coming out the defrost vents.

So when I stopped at work, I did some testing. Here is what i found:

control knob on defrost setting-> air comes out defrost vents only
control knob on defrost/ floor mix setting-> air comes out defrost and floor vents only
control knob on floor vents only-> air comes out defrost and floor vents only
control knob on dash/ floor mix setting-> air comes out dash and floor vents only
control knob on dash vents only-> air comes out dash vents only

So everything seems to be working just fine except the the floor vents only setting. Anyone have any ideas on this?

CreepMSU is offline   Reply With Quote
Unread 03-17-2014, 12:31 PM   #2
NAMoulton
Registered User
2010 KK Liberty 
 
Join Date: Dec 2013
Location: Harrisonburg, VA
Posts: 337
Quote:
Originally Posted by CreepMSU View Post
Hey Folks,

I have a 2011 Liberty with about 50,000 miles.

Now, before I start, I would like to say that I honestly don't know if it has always done this or if it should do this. This morning, I went to warm it up. I put the heat all the way up and put the control dial on defrost as per normal. When i was driving to work, I switched the control knob to the floor vents only setting and noticed that air was still coming out the defrost vents.

So when I stopped at work, I did some testing. Here is what i found:

control knob on defrost setting-> air comes out defrost vents only
control knob on defrost/ floor mix setting-> air comes out defrost and floor vents only
control knob on floor vents only-> air comes out defrost and floor vents only
control knob on dash/ floor mix setting-> air comes out dash and floor vents only
control knob on dash vents only-> air comes out dash vents only

So everything seems to be working just fine except the the floor vents only setting. Anyone have any ideas on this?
I have this issue too, I have to turn off my air wait 3 seconds turn the dial to feet and then turn air back on...I'm not a genius in the HVAC of a vehicle but I think the air is just stronger than the selector-switch-motor-thingy and yeah... haha
NAMoulton is offline   Reply With Quote
Unread 03-17-2014, 12:59 PM   #3
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst, NY
Posts: 1,125
Never heard that fix, I'm gonna have to try it. Anyways, I have the same problem(2011 as well). Took in in and the dealer told me they all do it....
__________________
2011 Deep Cherry Red KK - Skyslider - OME 927/731 - Bilstein Shocks - 1/4" Spacer Plate - 3/8" Clevis - Al's A-arms - 245/75-16 Duratracs
Bmxer524 is online now   Reply With Quote
Unread 03-17-2014, 01:32 PM   #4
CreepMSU
Registered User
 
Join Date: Mar 2014
Location: Redford, Michigan
Posts: 2
wierd. I will have to try that. I am glad I am not the only one, but i wish i knew what the actual issue was.....
CreepMSU is offline   Reply With Quote
Unread 03-17-2014, 01:39 PM   #5
cherox
Registered User
2012 KK Liberty 
 
Join Date: Oct 2007
Location: Boston, MA
Posts: 204
I noticed mine does the same thing
cherox is offline   Reply With Quote
Unread 03-17-2014, 01:51 PM   #6
Stang977
Member
2012 KK Liberty 
 
Join Date: Dec 2012
Location: White Plains, NY
Posts: 223
Yup, same here. Heard it was a weak Blend Door Control (thingy) I was going to have it checked as soon as the weather breaks (if ever)......
__________________
Me- 2012 KK, Latitude, Mineral Grey, "Cherokee" Moulding,
JBA Tommudd 3 1/2" Econolift
265/70R16 Nitto Terra's
Fuel Revolver 16X8

Her- 2011 WK2 Laredo X, Brilliant Black
Stang977 is offline   Reply With Quote
Unread 03-17-2014, 07:34 PM   #7
micherokee
Junior Member
2012 KK Liberty 
 
Join Date: Jan 2007
Location: WESTLAND, MICHIGAN
Posts: 75
Yea,My 2012 does it to.
__________________
2012 Liberty Canyon Brown Pearl
245/70/16 Michelin LTX AT2
  • Black Rock Rims
    Gibson Exhaust
    K&N filters
    Front&Rear Hooks
    Rear Taillight Guards
micherokee is offline   Reply With Quote
Unread 03-17-2014, 07:41 PM   #8
LKWJEEPER
Registered User
2009 KK Liberty 
 
Join Date: Nov 2012
Location: Clover, South Carolina
Posts: 1,007
Not to thread hijack but Its on the premise of being crazy. My rear wiper sometimes doesn't shut off when I turn it off. Sometimes I have to turn it on and then off to get it t stop.

Sent from AutoGuide.com Free App
LKWJEEPER is offline   Reply With Quote
Unread 03-18-2014, 03:28 AM   #9
marlon_jbt
Registered User
2010 KK Liberty 
 
Join Date: Apr 2003
Location: Detroit, MI
Posts: 1,133
Yeah, they all do it...
__________________
Red Jeep Club member # 264
marlon_jbt is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.