HELP! Newbie...jeep liberty will not start...giving code pO837 - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 04-20-2013, 04:35 PM Thread Starter
lildeebone
Registered User
2002 KJ Liberty 
 
Join Date: Apr 2013
Location: memphis
Posts: 9
HELP! Newbie...jeep liberty will not start...giving code pO837

jeep drove fine all day. It will not start back up. Sensory Key light on the dash is on again.

I have had this jeep five years never had a problem. I have had my ignition change out and new key programmed. I have had new PCM put in. It drives for about three days before the problem happens. The truck just turns over. Probaly tomorrow It will start up. I was wondering does anyone know what else will cause the sensory key light to come on if it's not the key? Any sensors or anything that could be going bad? I did just check. I got code PO837 . Could someone tell me what the code is and if it would cause the sensory key light to come on?

Please help

lildeebone is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-20-2013, 08:47 PM
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: Phoenix
Posts: 3,289
Not sure about the sentry key Illum. but a search of the innerweb gave me some info regarding the transfer case position sensor. Try finding the connector on that sensor and make sure it is connected and making good clean contact.

91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35@3.07
12 Cherokee 4x4,3.7L,42RLE/MP1522, D30M/8.25@3.73
Emission test=YES
"Non Vi Sed, Arte"
Drednot is offline  
post #3 of 3 Old 04-21-2013, 04:33 PM Thread Starter
lildeebone
Registered User
2002 KJ Liberty 
 
Join Date: Apr 2013
Location: memphis
Posts: 9
I took he battery cables off for about 4hrs...put them back on...now it's starting up. It will go dead sometimes..but at least i made it back to my driveway...could the Crank or cam shaft sensor make it do that? i let it run for about 1hr. it cranks back up and runs...but i don't think the problem is fixed. it's been doing that for about three weeks...if i drive it somewhere it will die on me or not crank!
lildeebone is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome