Help! - JeepForum.com
 
LinkBack Thread Tools
post #1 of 7 Old 08-19-2010, 05:17 PM Thread Starter
MikePM
Registered User
 
Join Date: May 2010
Location: Kansas
Posts: 12
Help!

This morning when I started my jeep i noticed that the windshield wipers were on and I can't turn them off! Also, the blinkers don't work. Everything else is working fine - does this sound like a fuse issue or some other kind of wiring problem? Thanks.

2008 Jeep liberty

MikePM is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 08-19-2010, 07:30 PM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Sounds like some sort of wiring issue, but checking the fuses cannot hurt. richd is usually good with things like this.

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #3 of 7 Old 08-19-2010, 10:25 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by MikePM View Post
This morning when I started my jeep i noticed that the windshield wipers were on and I can't turn them off! Also, the blinkers don't work. Everything else is working fine - does this sound like a fuse issue or some other kind of wiring problem? Thanks.

2008 Jeep liberty
You can try to unhook your battery cable and see if this will rest the PCM,just helped someone with a Charger who had wipers that wouldnt shut off,and disconnecting the battery for a minute worked.
There is a TSB for this ,most likely reprogram the PCM:

Make : JEEP Model : LIBERTY Year : 2008
Manufacturer : CHRYSLER GROUP LLC
Service Bulletin Number : 07049 Date of Bulletin : NOV 20, 2007
NHTSA Item Number : 10023638
Component : ELECTRICAL SYSTEM: SOFTWARE
Summary :
UNABLE TO SHIFT OUT OF PARK OR FRONT WIPERS AND HEADLAMPS DEFAULT TO (ON). *NJ
richd is offline  
post #4 of 7 Old 10-24-2010, 06:08 PM Thread Starter
MikePM
Registered User
 
Join Date: May 2010
Location: Kansas
Posts: 12
Fixed

Sorry didn't mean to leave this open ended. It was an easy fix, I just unplugged the battery, reconnected it, and now it's good to go. No idea what would cause that problem.
MikePM is offline  
post #5 of 7 Old 10-25-2010, 04:45 AM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Good to hear everything is OK now.

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #6 of 7 Old 10-25-2010, 05:15 AM
otlip
Registered User
 
Join Date: Apr 2010
Location: nj
Posts: 109
Same problem

I had the same issue but with one twist. I could start the car, but not take it out of gear. The wipers would not turn off and the head lights were on. I just disconnected the battery cable and then re-connected it. That solved the problem. Two dealers gave me the same story, "never heard of that problem". But there is a memo regarding this problem and I plan on bring it to the attention of the dealer. I'll let everyone know of the outcome.

Rich
otlip is offline  
post #7 of 7 Old 10-25-2010, 03:19 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by otlip View Post
I had the same issue but with one twist. I could start the car, but not take it out of gear. The wipers would not turn off and the head lights were on. I just disconnected the battery cable and then re-connected it. That solved the problem. Two dealers gave me the same story, "never heard of that problem". But there is a memo regarding this problem and I plan on bring it to the attention of the dealer. I'll let everyone know of the outcome.

Rich
Just give them this TSB and they should take care of it- Make : JEEP Model : LIBERTY Year : 2008
Manufacturer : CHRYSLER GROUP LLC
Service Bulletin Number : 07049 Date of Bulletin : NOV 20, 2007
NHTSA Item Number : 10023638
Component : ELECTRICAL SYSTEM: SOFTWARE
Summary :
UNABLE TO SHIFT OUT OF PARK OR FRONT WIPERS AND HEADLAMPS DEFAULT TO (ON). *NJ
richd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome