Heater Control - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Heater Control

Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955XHD Heavy-Duty Hood Latches for JK and TJ available at OcoFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 02-23-2013, 04:38 PM   #1
jeepman6655
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2012
Location: Auburn, Ma.
Posts: 42
Heater Control

We have an 11 KK Limited. We noticed when we move the control to have the heat come out only at the foot wells nothing happens. It all seems to be coming out at the defrost. Also I find only one outlet in the footwells....passenger side and there seems to be no outlet on the driver's side. Any help would be appriciated.

jeepman6655 is offline   Reply With Quote
Unread 02-23-2013, 07:52 PM   #2
nessus39
Registered User
 
Join Date: Feb 2013
Posts: 6
My 12 is doing the same with the heater. Taking it back too the dealer
nessus39 is offline   Reply With Quote
Unread 02-24-2013, 05:13 PM   #3
nessus39
Registered User
 
Join Date: Feb 2013
Posts: 6
New stuff on my 70th limited
nessus39 is offline   Reply With Quote
Unread 02-24-2013, 05:14 PM   #4
nessus39
Registered User
 
Join Date: Feb 2013
Posts: 6
New stuff on my 70th anniversary limited

forumrunner_20130224_191333.jpg
nessus39 is offline   Reply With Quote
Unread 02-17-2014, 06:42 PM   #5
nfodzy
Registered User
2011 KK Liberty 
 
Join Date: Oct 2013
Location: Thunder Bay, Ontario
Posts: 71
Quote:
Originally Posted by jeepman6655 View Post
We have an 11 KK Limited. We noticed when we move the control to have the heat come out only at the foot wells nothing happens. It all seems to be coming out at the defrost. Also I find only one outlet in the footwells....passenger side and there seems to be no outlet on the driver's side. Any help would be appriciated.
Did you find out what the issue was? I'm experiencing the same problems now..
__________________
2011 Brilliant Black KK Sport - 245/75/16 GY Wrangler Territory, HID's, Drake Shifter Knob, Dynomax
nfodzy is offline   Reply With Quote
Unread 02-17-2014, 08:49 PM   #6
DarkSport11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Farmingville, New York
Posts: 180
I'm being told it has to do with the blend door having too much play in it. I'm having the same issue. I read on another forum that the HVAC box has to be replaced, about a 6 hour job according to the dealer and under warranty. I'll make an appointment to have it taken care of one of these days when I have time. As cold as it's been I'm just glad to have heat even if it's blowing in my face all of time.
__________________
2002 KJ Sport 4X4 in Dark Garnet Pearlcoat
2011 KK Sport 4X4 in Dark Charcoal Pearlcoat
DarkSport11 is offline   Reply With Quote
Unread 02-17-2014, 09:10 PM   #7
nfodzy
Registered User
2011 KK Liberty 
 
Join Date: Oct 2013
Location: Thunder Bay, Ontario
Posts: 71
Quote:
Originally Posted by Garnet02Sport View Post
I'm being told it has to do with the blend door having too much play in it. I'm having the same issue. I read on another forum that the HVAC box has to be replaced, about a 6 hour job according to the dealer and under warranty. I'll make an appointment to have it taken care of one of these days when I have time. As cold as it's been I'm just glad to have heat even if it's blowing in my face all of time.
Haha yeah no kidding me too, I dont know what Id do if I didnt have heat. I was smart too before winter, late november I had my blower motor replaces cause it was making loud noises which was under warranty too So ill have to see if this problem is under my warranty and see what it really is!
__________________
2011 Brilliant Black KK Sport - 245/75/16 GY Wrangler Territory, HID's, Drake Shifter Knob, Dynomax
nfodzy is offline   Reply With Quote
Unread 02-28-2014, 10:08 AM   #8
jhealy1191
Registered User
2014 MK Compass 
 
Join Date: Feb 2014
Location: Chicago, IL
Posts: 9
Thank you!

I just got my '10 Liberty a week ago and with this lovely Chicago winter the heat, or lack thereof, is driving me crazy. Everything else I love!

Calling the dealer this afternoon. Do you know if its a faulty part or just something that has been improved on recently?
jhealy1191 is offline   Reply With Quote
Unread 02-28-2014, 10:40 AM   #9
DarkSport11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Farmingville, New York
Posts: 180
I believe it's a faulty part, quite a few of them out there do the same thing.
__________________
2002 KJ Sport 4X4 in Dark Garnet Pearlcoat
2011 KK Sport 4X4 in Dark Charcoal Pearlcoat
DarkSport11 is offline   Reply With Quote
Unread 02-28-2014, 10:58 AM   #10
jhealy1191
Registered User
2014 MK Compass 
 
Join Date: Feb 2014
Location: Chicago, IL
Posts: 9
Seeing as my car is a 10 I don't think it'd be covered under warranty but definitely still something worth looking into even replacing myself.
jhealy1191 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.