Heater Control - JeepForum.com

 
LinkBack Thread Tools
post #1 of 10 Old 02-23-2013, 04:38 PM Thread Starter
jeepman6655
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2012
Location: Auburn
Posts: 42
Heater Control

We have an 11 KK Limited. We noticed when we move the control to have the heat come out only at the foot wells nothing happens. It all seems to be coming out at the defrost. Also I find only one outlet in the footwells....passenger side and there seems to be no outlet on the driver's side. Any help would be appriciated.

jeepman6655 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 02-23-2013, 07:52 PM
nessus39
Registered User
 
Join Date: Feb 2013
Posts: 6
My 12 is doing the same with the heater. Taking it back too the dealer
nessus39 is offline  
post #3 of 10 Old 02-24-2013, 05:13 PM
nessus39
Registered User
 
Join Date: Feb 2013
Posts: 6
New stuff on my 70th limited
nessus39 is offline  
post #4 of 10 Old 02-24-2013, 05:14 PM
nessus39
Registered User
 
Join Date: Feb 2013
Posts: 6
New stuff on my 70th anniversary limited

forumrunner_20130224_191333.jpg
nessus39 is offline  
post #5 of 10 Old 02-17-2014, 06:42 PM
nfodzy
Registered User
2011 JK Wrangler 
 
Join Date: Oct 2013
Location: Thunder Bay
Posts: 112
Quote:
Originally Posted by jeepman6655 View Post
We have an 11 KK Limited. We noticed when we move the control to have the heat come out only at the foot wells nothing happens. It all seems to be coming out at the defrost. Also I find only one outlet in the footwells....passenger side and there seems to be no outlet on the driver's side. Any help would be appriciated.
Did you find out what the issue was? I'm experiencing the same problems now..

2011 JKU - 1" Bodylift + 2.5" Suspension - 295/70r17 Cooper Discoverer Pro on Pro Comp La Paz
nfodzy is offline  
post #6 of 10 Old 02-17-2014, 08:49 PM
DarkSport11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Farmingville
Posts: 205
I'm being told it has to do with the blend door having too much play in it. I'm having the same issue. I read on another forum that the HVAC box has to be replaced, about a 6 hour job according to the dealer and under warranty. I'll make an appointment to have it taken care of one of these days when I have time. As cold as it's been I'm just glad to have heat even if it's blowing in my face all of time.

2011 KK Sport 4X4 in Dark Charcoal Pearlcoat
DarkSport11 is offline  
post #7 of 10 Old 02-17-2014, 09:10 PM
nfodzy
Registered User
2011 JK Wrangler 
 
Join Date: Oct 2013
Location: Thunder Bay
Posts: 112
Quote:
Originally Posted by Garnet02Sport View Post
I'm being told it has to do with the blend door having too much play in it. I'm having the same issue. I read on another forum that the HVAC box has to be replaced, about a 6 hour job according to the dealer and under warranty. I'll make an appointment to have it taken care of one of these days when I have time. As cold as it's been I'm just glad to have heat even if it's blowing in my face all of time.
Haha yeah no kidding me too, I dont know what Id do if I didnt have heat. I was smart too before winter, late november I had my blower motor replaces cause it was making loud noises which was under warranty too So ill have to see if this problem is under my warranty and see what it really is!

2011 JKU - 1" Bodylift + 2.5" Suspension - 295/70r17 Cooper Discoverer Pro on Pro Comp La Paz
nfodzy is offline  
post #8 of 10 Old 02-28-2014, 10:08 AM
jhealy1191
Registered User
2014 MK Compass 
 
Join Date: Feb 2014
Location: Chicago
Posts: 9
Thank you!

I just got my '10 Liberty a week ago and with this lovely Chicago winter the heat, or lack thereof, is driving me crazy. Everything else I love!

Calling the dealer this afternoon. Do you know if its a faulty part or just something that has been improved on recently?
jhealy1191 is offline  
post #9 of 10 Old 02-28-2014, 10:40 AM
DarkSport11
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Farmingville
Posts: 205
I believe it's a faulty part, quite a few of them out there do the same thing.

2011 KK Sport 4X4 in Dark Charcoal Pearlcoat
DarkSport11 is offline  
post #10 of 10 Old 02-28-2014, 10:58 AM
jhealy1191
Registered User
2014 MK Compass 
 
Join Date: Feb 2014
Location: Chicago
Posts: 9
Seeing as my car is a 10 I don't think it'd be covered under warranty but definitely still something worth looking into even replacing myself.
jhealy1191 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome