Heater Blowing Only Cold Air - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 11-24-2013, 06:02 AM Thread Starter
nws2002
Registered User
2011 KK Liberty 
 
Join Date: Apr 2013
Location: Tulsa
Posts: 13
Heater Blowing Only Cold Air

First issue with my 2011 KK. Just bummed it's a heater issue since the EVIC showed it to be 24 degrees this morning and it probably won't warm up much today. Just rolled of 70k miles this weekend, so obviously way out of warranty.

Left work after a night shift, got in started it up, switched on the heated seat and left. Waited for the temp gauge to hit mid-range and then turned the heat on full blast, only to start feeling freezing cold air out of the floor and defrost vents. Spun the temp dial back and forth a few times, no change. Tried turning the fan on and off a few times, fan changed speeds but still the cold air. Tried changing the air flow between the various settings, switched over between the various vents but still freezing cold air.

No anti-freeze smell or anything. I'm really hoping it's not a heater core and was wondering if there's anything simple to check and try before taking it into the dealer on Monday.

nws2002 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-24-2013, 08:17 PM
Babaki
Registered User
2012 KK Liberty 
 
Join Date: Aug 2013
Location: North Jersey
Posts: 115
blend door. search the forum there are posts about it.
Babaki is offline  
post #3 of 8 Old 11-25-2013, 09:28 AM
COLORADO
Registered User
2007 JK Wrangler 
 
Join Date: Mar 2007
Location: COLORADO SPRINGS
Posts: 165
Stuck thermostat
COLORADO is offline  
post #4 of 8 Old 11-25-2013, 10:31 AM
Babaki
Registered User
2012 KK Liberty 
 
Join Date: Aug 2013
Location: North Jersey
Posts: 115
Quote:
Originally Posted by COLORADO View Post
Stuck thermostat
if he had a stuck thermostat wouldn't his temp gauge read cold all the time? he said the temp went up the middle. so to me that seems like his thermostat is working properly no?
Babaki is offline  
post #5 of 8 Old 11-25-2013, 01:39 PM Thread Starter
nws2002
Registered User
2011 KK Liberty 
 
Join Date: Apr 2013
Location: Tulsa
Posts: 13
Ended up taking it to the dealership this morning, after I tried all the tricks I could find here. They replaced the HVAC box because one of the motors that controls the doors was bad. They also replaced the blower motor because it was noisy and they said there was a bearing getting ready to go out.
nws2002 is offline  
post #6 of 8 Old 12-02-2013, 05:54 PM
jaws1554
Registered User
 
Join Date: Dec 2013
Posts: 5
water pump

just had mine changed and now have hot air.
jaws1554 is offline  
post #7 of 8 Old 12-02-2013, 05:56 PM
jaws1554
Registered User
 
Join Date: Dec 2013
Posts: 5
water pump

took my 08 to my buddy's garage and they changed the water pump and now have hot air.
jaws1554 is offline  
post #8 of 8 Old 12-02-2013, 06:01 PM
jaws1554
Registered User
 
Join Date: Dec 2013
Posts: 5
I have an 08 with same problem and had to put a new water pump on.
jaws1554 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome