heat not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > heat not working

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 10-08-2013, 06:24 PM   #1
bluebuggy
Registered User
2000 WJ 
 
Join Date: Mar 2009
Location: new albany IN
Posts: 40
heat not working

I have a 2010 kk sprot. Today I turned on the heater and got alot of cold air. The pass side had somewhat warm air.

Done a seach and found a few guys had the same problem they flushed the core and all was good. Some had to replace it.

So I done that flushed everything as good as I could started it up. It works better but not great. So I may have to swap it out.

However before I do that I have something else going on to. I let the jeep run about 15 mins got up to temperature looking it over and crack open the air port to see if any air wad there and there was but then I tured to far and the plug came out and it had to pressure. I then drove about 5 miles got out and pulled the cap off again no pressure at all.

Is this right?? Im not had any leaks or overheating so I dont think its the cap but not sure.

Anyone else have this should I just buy a cap and see if it helps?

Any help or ideas would be great


Thanks

bluebuggy is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.