Heat controls not working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Heat controls not working

Rough Country Deals at JeepHut.comEliminate Hood Flutter!!!Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 02-11-2014, 09:48 AM   #1
lakehimself
Registered User
 
Join Date: Nov 2013
Posts: 20
Heat controls not working

None of the heat controls work on the liberty. The defroster constantly blows hot air no matter what the setting is on, while it's nice because it's winter it gets overwhelmingly hot. Any suggestions?

lakehimself is offline   Reply With Quote
Unread 02-11-2014, 10:21 AM   #2
RENE65
Registered User
2008 KK Liberty 
 
Join Date: Dec 2011
Location: LAVAL, QUEBEC
Posts: 150
Try unplugging the battery 10 minutes.Common fix for a lot of electrical gremlins on the Libby.
RENE65 is offline   Reply With Quote
Unread 02-11-2014, 01:39 PM   #3
lakehimself
Registered User
 
Join Date: Nov 2013
Posts: 20
Thanks it worked!
lakehimself is offline   Reply With Quote
Unread 02-11-2014, 01:43 PM   #4
RENE65
Registered User
2008 KK Liberty 
 
Join Date: Dec 2011
Location: LAVAL, QUEBEC
Posts: 150
Glad for you
RENE65 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.