Got a rodent issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 10-30-2010, 12:41 PM Thread Starter
acasa521
Registered User
 
Join Date: Oct 2010
Location: iola
Posts: 1
Got a rodent issue

Anyone have a wiring diagram for the 2009 liberty 3.7l. Have some mouse dammage that left a fairly heavy gauge black w/pink wire mustly chewed( through the plastic lum, belowbrake fluid res.). I want educate myself as best I can before I have a fix done, or repair myself.
Thanks

acasa521 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-21-2010, 02:59 PM
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
email me I can give you the wiring diagram. Where exactly did the mouse chew?

2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
weird tranny issue VMF KK Liberty Forum 3 07-20-2010 12:35 PM
Fuse problem in my 2008 KK....NOT! A RODENT! Huntyeraws KK Liberty Forum 12 07-14-2010 06:51 AM
KK 4x4 question (do I have an issue?) Dabitz KK Liberty Forum 2 12-20-2009 08:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome