Forum Newb & 2010 KK Throwing P050 Code - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Forum Newb & 2010 KK Throwing P050 Code

Eliminate Hood Flutter!!!WJ Shackle Tabs: Tow-Hook Replacements2014 Spartan Locker Special - While Supplies Last! Dana 3

Reply
Unread 08-06-2011, 05:36 PM   #1
beertender
Registered User
2010 KK Liberty 
 
Join Date: Aug 2011
Location: auburndale, fl
Posts: 2
Forum Newb & 2010 KK Throwing P050 Code

Hi all,

I just found this forum, looks like a great place to learn more about my jeep from other enthusiasts.

I am looking for help. My 2010 KK is a renegade 4x4 with just over 11k miles. We have owned it since new and bought it last labor day so it is almost a year old. Have kept it up to date with maintenance (oil changes).

Anyway engine threw two codes today on my better half, needless to say she isn't happy. Both codes were P050 - rough idle detected, we are in Florida and it is hot. She said she was in reverse and put the truck into Drive and it was a noticeable rough idle condition and the SEL came on.

Has anyone seen this problem and or can you point me in the right direction as to what I should be looking at for the culprit? I run premium fuel so I am not sure it would be a fuel problem unless I got some bad gas (no pun intended).

Thanks in advance for any and all insight....

Happy Jeepin!

beertender is offline   Reply With Quote Quick reply to this message
Unread 08-06-2011, 09:46 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,106
The code should read PO050 which means HO2S Heater Control Circuit (Bank 2, Sensor 1).So its the front sensor on passenger side of engine.It could be either a wiring problem,or a bad O2 sensor.This should be under Warranty.Running premium is not needed on the 3.7,Regular,or mid-grade should be fine.In my KK I run mid-grade and runs good on it.
richd is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.