Fan moves in/out and leaks oil 2010 liberty - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Fan moves in/out and leaks oil 2010 liberty

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! ECGS Black Friday Sale!!1993-1998 Jeep Grand Cherokee Stainless Steel Exhaust Mani

Reply
Unread 03-08-2014, 06:23 AM   #1
ThorriorZ
Registered User
2010 KK Liberty 
 
Join Date: Mar 2014
Location: amery, Wisconsin
Posts: 3
Fan moves in/out and leaks oil 2010 liberty

Pulling into work today I heard a rattling sound coming from under the hood. I quickly parked and popped the hood only to see oil all over the front of my engine. After further inspection the fan and pulley appeared to be moving in and out of the front of the engine block. I have never seen this before and was wondering what exactly it could be. I initially thought it was my timing assembly but now think it might be the fan clutch put a hole in my timing case. Any thoughts?

ThorriorZ is offline   Reply With Quote Quick reply to this message
Unread 03-08-2014, 06:51 AM   #2
brucecadieux
Registered User
2011 KK Liberty 
 
Join Date: Jan 2014
Location: Wales, MA
Posts: 17
Liberty has an electric cooling fan. Not sure how it could possibly be moving in and out of the engine block. Unless a fan clutch was added. Needless to say you likely need a new water pump.
brucecadieux is offline   Reply With Quote Quick reply to this message
Unread 03-08-2014, 07:21 AM   #3
ThorriorZ
Registered User
2010 KK Liberty 
 
Join Date: Mar 2014
Location: amery, Wisconsin
Posts: 3
Yeah I'm no mechanic. hahaha. Would the water pump be the culprit of the oil leak?
ThorriorZ is offline   Reply With Quote Quick reply to this message
Unread 03-08-2014, 07:48 AM   #4
brucecadieux
Registered User
2011 KK Liberty 
 
Join Date: Jan 2014
Location: Wales, MA
Posts: 17
Are you sure it is oil and not anti freeze?
brucecadieux is offline   Reply With Quote Quick reply to this message
Unread 03-08-2014, 08:35 PM   #5
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 593
+1 for antifreeze. Same thing happened to me and it was a bad waterpump. Do you hear a whining noise coming from under the hood while it's running?
huntb is offline   Reply With Quote Quick reply to this message
Unread 03-09-2014, 05:09 AM   #6
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: phoenix, az
Posts: 1,425
If you have the factory tow package, it has a mechanical fan also. Something has definitely given up the ghost and needs to be remedied before it tears loose. Sounds like the water pump bearing or the fan clutch bearing.





__________________
91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35
12 Cherokee 4x4,3.7L,
"Non Vi Sed, Arte"
Drednot is offline   Reply With Quote Quick reply to this message
Unread 03-09-2014, 09:40 AM   #7
ThorriorZ
Registered User
2010 KK Liberty 
 
Join Date: Mar 2014
Location: amery, Wisconsin
Posts: 3
Thanks guys turns out it was the water pump. Got it out and replaced it with a new one and runs like a champ again!
ThorriorZ is offline   Reply With Quote Quick reply to this message
Unread 03-09-2014, 01:23 PM   #8
mattg78
Registered User
2009 KK Liberty 
 
Join Date: Aug 2013
Location: sound beach, NY
Posts: 6
recall on waterpump

When we had our 2010 liberty, there was a recall on the waterpump.
mattg78 is offline   Reply With Quote Quick reply to this message
Unread 03-09-2014, 02:45 PM   #9
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,397
Quote:
Originally Posted by ThorriorZ View Post
Thanks guys turns out it was the water pump. Got it out and replaced it with a new one and runs like a champ again!
Great news! Was it easy to do?
__________________
OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 03-09-2014, 05:29 PM   #10
Poncherello
Moderator
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Paterson, New Jersey
Posts: 1,009
Glad you had it fixed. I just had the water pump replaced in mine for 3rd time along with the power steering pump and belt tensioner. It was about. 70k miles. All I can say I know have 75k miles on her and Good Year SRA's are still holding up lol!

Dredd- The mechanical fan installed on the Lib with the tow package. Would you or could you measure the diameter? Maybe cost effective if I go with an aftermarket instead of Mopar.
__________________
When you get knee-deep in a situation, floor it.
Poncherello is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.