Electrical Gremlins - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Electrical Gremlins

THE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaSavvy Billet LED Tail LightsCurrie

Reply
Unread 11-22-2013, 05:32 PM   #1
tservo
Registered User
2009 KK Liberty 
 
Join Date: Nov 2013
Location: Kettering, OH
Posts: 4
Electrical Gremlins

Greetings. I have a 2009 Liberty with 54k that has developed some vexing electrical problems. In rough order of occurrence:

1. Airbag dash light and chime goes off at random times (been happening for about 6 months)
2. Seat belt warning light and chime go off at random (approximately the same length of time)
3. Radio would be working fine, then produce and audible <click> and shut off. Sometimes would come back on by itself, more often it won't. As of last week, it is non-functional.
4. Red light right in middle of tach and odo (security system indicator according to manual) turned on when car was started. We don't have a security system installed. (about two weeks ago; has not happened again)
5. When turning the car on, starter runs but engine does not crank at all. Wife held the key in the start position for about 30 seconds and it never turned over. (Happened two days ago.)

We replaced the worn out original battery with a much nicer one last month. I've read on some other forums about some of the fuses to check (#s 9 and 34). Of course our local dealer would love nothing more than to charge us $89/hr to track down the problem, but I'm not sure I'm ready to just burn a pile of money.

So I have two questions:
Has anyone else had similar seemingly random, non-reproduceable problems with their 2009 Liberties?, and
Does this portend something more critical (and expensive) happening in the future?

We traded in our 2007 Liberty when it developed a disturbing clunk in the brake pedal (you could feel the pedal give and then snap back) that the dealer never could figure out. We've not had any major issues with the 2009, but the Boss is having a harder time convincing me to let her get a Rubicon when this Jeep is done.

Any ideas?

-tservo

tservo is offline   Reply With Quote Quick reply to this message
Unread 11-22-2013, 08:33 PM   #2
Katmandu
Registered User
2013 JK Wrangler 
 
Join Date: Aug 2005
Location: Troy, Ohio
Posts: 371
Bad body module. Causes havoc everywhere.

There's a TSB out for this somewhere.

I believe the dealer will replace it under Warranty.
Katmandu is offline   Reply With Quote Quick reply to this message
Unread 11-23-2013, 07:38 AM   #3
tservo
Registered User
2009 KK Liberty 
 
Join Date: Nov 2013
Location: Kettering, OH
Posts: 4
Electrical gremlins

Katmandu - is this coming from experience?

-tservo
tservo is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.