JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   KK Liberty Forum (http://www.jeepforum.com/forum/f292/)
-   -   DDM HID kit flickering <no haters please> (http://www.jeepforum.com/forum/f292/ddm-hid-kit-flickering-no-haters-please-1690385/)

Jeepism 10-16-2013 10:22 AM

DDM HID kit flickering <no haters please>
 
I purchased an HID kit from DDM tuning and installed it just as the directions said. The bulbs work perfectly fine when the car is not running but once I start the car and the car is running the bulbs start flickering and going crazy. I even installed a wiring harness with a 30 amp fuse and that didnt seem to change anything or fix the problem. I was wondering if anyone out there had any ideas on why this is happening and could help me out. Open to try anything. Thanks!!!

LUV4JEEP 10-16-2013 11:23 AM

Are the lights secure in the headlight housing??? If not the movement of the engine being on is causing them to "shake" not flicker check and make sure there not loose

huntb 10-16-2013 11:25 AM

A lot of people have this problem when installing HIDs in their Libertys for some reason and usually just take them out. Better on my eyes too

LUV4JEEP 10-16-2013 11:37 AM

I have them installed on my KK ....shush don't let Tom see this....... And so far there amazing (besides having to adjust them a million times so I'm not cause people to have seizures) I've had them on for almost 6 months still going strong

tommudd 10-16-2013 02:01 PM

Then I won't have to say
remove them :rofl:and not blind everyone else on the road
To the OP, like mentioned above lots have tried and same issues,
plus not legal

Poncherello 10-16-2013 07:22 PM

I purchased a set of Wagner 9005 BLX2 Bright headlight bulbs from Rock Auto for my Gf's Camry and they work awesome for like $20. Now, they are only the brights so you're not blinding people all of the time. What's nice about the Camry the headlight have separate bulbs for low beams and high beams. I wish the Lib was set up the same way. If those HID's don't work out check out Rock Auto they have a nice selection of bulbs some of other makes of some good bulbs are Piaa, and Hella. There is a vendor section too on the forum that may help you out if the HID's don't work out.

Good luck

tjkj2002 10-16-2013 08:01 PM

Quote:

Originally Posted by Jeepism (Post 16886057)
Open to try anything. Thanks!!!

Put the correct halogen bulbs back in,problem solved,legal,and no more flickering.

Babaki 10-17-2013 07:12 AM

Quote:

Originally Posted by Jeepism (Post 16886057)
I purchased an HID kit from DDM tuning and installed it just as the directions said. The bulbs work perfectly fine when the car is not running but once I start the car and the car is running the bulbs start flickering and going crazy. I even installed a wiring harness with a 30 amp fuse and that didnt seem to change anything or fix the problem. I was wondering if anyone out there had any ideas on why this is happening and could help me out. Open to try anything. Thanks!!!

sounds like a bad ground to me.

tjkj2002 10-17-2013 07:58 AM

Quote:

Originally Posted by Babaki (Post 16910689)
sounds like a bad ground to me.

It's not a bad ground,it's because the WCM controls the lights and does not like HID's since it was programed for halogen bulbs.

priebe 10-17-2013 09:26 AM

I bet if you wired in some sort of resistor it would work. There is not enough load on the line and the control module is freaking out. You went from like a 55 watt high amp draw down to a 5 watt low amp draw on that circuit. There are kits out there to add resistors to the headlight wiring or just pick up a couple from RadioShack for like $2.

tommudd 10-17-2013 09:36 AM

If you follow on the various forums you would know several have tried these and tried many different things to make them work. In the end they DO NOT, and thats just trying to keep them on as they should be.
We won't even get into the issues with blinding everyone else on the roads due to the light scattering everywhere and being illegal.

Jeepism 10-17-2013 09:43 AM

Appreciate the feedback. The bulbs are secure but I will check the ground after work, and if that doesnt work ill run to radio shack and see about those resistors. If all else fails I guess ill send the HID's back and go back to the stock halogen bulbs. I just dont understand how some HID's work in a Liberty but then some dont. LUV4JEEP, what kit did you use?and did you use a wiring harness and resistors or just plug into the stock harness?

tommudd 10-17-2013 09:53 AM

Quote:

Originally Posted by Jeepism (Post 16914289)
Appreciate the feedback. The bulbs are secure but I will check the ground after work, and if that doesnt work ill run to radio shack and see about those resistors. If all else fails I guess ill send the HID's back and go back to the stock halogen bulbs. I just dont understand how some HID's work in a Liberty but then some dont. LUV4JEEP, what kit did you use?and did you use a wiring harness and resistors or just plug into the stock harness?

None really work if you come right down to it and are honest about it

Babaki 10-17-2013 11:13 AM

Quote:

Originally Posted by tommudd (Post 16914577)
None really work if you come right down to it and are honest about it

we get that you dont like them. however the dude asked a question as to why they are flickering.

tommudd 10-17-2013 11:21 AM

Quote:

Originally Posted by Babaki (Post 16916809)
we get that you dont like them. however the dude asked a question as to why they are flickering.

And that has been answered many times, they are not made for the Libertys so no matter how much mumbo jumbo you throw at them, they will not work
So the "dudes" question has been answered


The time now is 02:43 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.