Dash lights stops working while driving - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Dash lights stops working while driving

Black Friday- Cyber Monday Deals at jeepHutBlack Friday Deals !JcrOffroad Black Friday Sale!

Reply
Unread 06-13-2013, 01:00 PM   #1
brunolambert
Registered User
2008 KK Liberty 
 
Join Date: Feb 2013
Location: Sherbrooke, Qc
Posts: 149
Dash lights stops working while driving

Hello,

Had a weird experience today. Yesterday when I came back from work, all dash light stopped working (I noticed with flashers, when shutting ESP, no light in the dash).

Forgot about it when I got home. This morning, not a single light in the dash and front wiper would not stop. pulled out the wiper fuse, still no lights and could not change transmission out of park.

As an IT guy, all I could think of is: have you tried to turn it off and on again? it's what I did, unplug the battery and plug it back. Now everything works fine.

Seems like a stupid computer problem. Anyone ever got that?

brunolambert is offline   Reply With Quote Quick reply to this message
Unread 06-17-2013, 05:45 PM   #2
brunolambert
Registered User
2008 KK Liberty 
 
Join Date: Feb 2013
Location: Sherbrooke, Qc
Posts: 149
No one eh? Hopefully it was nothing.
__________________
2008 KK Sport, Light Graystone Pearlcoat, Selec-Trac II, tow package, Firestone Destination LE2
brunolambert is offline   Reply With Quote Quick reply to this message
Unread 06-17-2013, 05:54 PM   #3
RKK
Registered User
2012 KK Liberty 
 
Join Date: Apr 2013
Location: Ashburn, Virginia
Posts: 39
I heard similar stories, Tipm related issue I am guessing. Is there water involved any where, like water fording?
RKK is offline   Reply With Quote Quick reply to this message
Unread 06-17-2013, 06:40 PM   #4
brunolambert
Registered User
2008 KK Liberty 
 
Join Date: Feb 2013
Location: Sherbrooke, Qc
Posts: 149
no water fording in my case, no offroad at all actually.
brunolambert is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.