Cold start engine problem. Please help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Cold start engine problem. Please help

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 05-16-2010, 01:59 PM   #1
Steve16999
Registered User
2009 KK Liberty 
 
Join Date: May 2010
Location: Albany,NY
Posts: 5
Cold start engine problem. Please help

When first starting my liberty for the day if i give it gas in park it will go up to 2,000 rpm's then the engine jerks and send the rpms down a bit and keeps repeating this pattern.

I can litterally put the pedal to the floor and it will not go above 2,000 rpms

i called a jeep mechanic to see if there was some sort of cold start protection, he told me he owns the same liberty and something must be wrong.

If i put the car in gear this doesnt seem to happen, but im just driving around town at 30mph so the rpm's do not go much over 2,000 anyway. Im afraid to go back on the highway until i know what is causing this.) It also doesnt happen after i have been driving a short distance (i think this is because the engine has warmed up)

i live in upstate ny so it is relatively warm right now, so when i say cold start i just mean that it has been off for several hours or over night.

I bought this jeep a month ago from a dealer with 26k miles on it so i am worried at this point.

Steve16999 is offline   Reply With Quote Quick reply to this message
Unread 05-16-2010, 05:56 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
My first guess would be a vacuum leak,or possibly a EGR problem.You should have warranty from the place you bought it from,or the remainder of 3/36 from Chrysler.
richd is offline   Reply With Quote Quick reply to this message
Unread 05-21-2010, 10:01 AM   #3
Steve16999
Registered User
2009 KK Liberty 
 
Join Date: May 2010
Location: Albany,NY
Posts: 5
Update - my jeep is now back at the dealer and they have no idea what is causing this....

they have calls into Chrysler and emailed them...they "think" that it is a cold start rev limiter, except by all accounts otherwise none exists

has anyone else had this problem?

this is really frustrating!
Steve16999 is offline   Reply With Quote Quick reply to this message
Unread 05-21-2010, 10:39 AM   #4
Steve16999
Registered User
2009 KK Liberty 
 
Join Date: May 2010
Location: Albany,NY
Posts: 5
Well, chrysler called back

and they don't know

excellent.
Steve16999 is offline   Reply With Quote Quick reply to this message
Unread 05-21-2010, 10:41 AM   #5
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Tell em to fix it or give you another Jeep
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote Quick reply to this message
Unread 05-21-2010, 08:30 PM   #6
Steve16999
Registered User
2009 KK Liberty 
 
Join Date: May 2010
Location: Albany,NY
Posts: 5
Picked up my jeep from the dealer

well, they still couldn't find anything wrong

chrysler told them to do a flash update...apparently there is an update to the computer systems already

they told me it probably won't change anything but to try it anyway

If anyone could see if their 2009 liberty with the 3.7 has this happen to them it would indicate to me that this is a feature and not a problem.....the dealer was unable to achieve this information
Steve16999 is offline   Reply With Quote Quick reply to this message
Unread 05-21-2010, 11:15 PM   #7
sebush3
Registered User
 
Join Date: Apr 2010
Location: VA
Posts: 7
Problems like this; most notably the response from the dealer, are what make me hesitant to pull the trigger on a Liberty (i.e. Jeep product).
sebush3 is offline   Reply With Quote Quick reply to this message
Unread 05-21-2010, 11:43 PM   #8
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Quote:
Originally Posted by Steve16999 View Post
Picked up my jeep from the dealer

well, they still couldn't find anything wrong

chrysler told them to do a flash update...apparently there is an update to the computer systems already

they told me it probably won't change anything but to try it anyway

If anyone could see if their 2009 liberty with the 3.7 has this happen to them it would indicate to me that this is a feature and not a problem.....the dealer was unable to achieve this information
There are 2 things I would tell the dealer to check,first the IAC,and second,the TPS.Im assuming they checked for vacuum leaks.I have a 08 KK,and it doesnt do this,If I floored mine,it probably would damage my engine.
richd is offline   Reply With Quote Quick reply to this message
Reply

Tags
2009 liberty , cold start , engine , problem

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.