Code Soup for dinner... Yikes... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Code Soup for dinner... Yikes...

Spartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREERough Country Jeep Suspension Deals at Rockridge 4WD!Bds fox ipf 2.0 racing series shocks now available at rock

Reply
Unread 10-12-2014, 07:23 PM   #1
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron, Ohio (OH)
Posts: 423
Code Soup for dinner... Yikes...

So, I thought that the right wheel speed sensor connector is loose again.

Rained on Wednesday and on the way to work the traction control, ABS, service 4wheel drive lights all came on. No biggie.. it happened before and I reset the pins in the connector and all was well. So figured I'd crawl under and fix it up tonight.

Important note here... everything else seems to be working OK... nothing doesn't work...

So, I hooked up the Hypertech to scan for codes... IT PULLED 12!!!!!!

U0249 - Lost communication with vehicle entertainment module
U0415 - Implausible Data ABS
U0429 - Implausible Data from SCM (steering control module)
U0164 - Lost communication with HVAC
U0204 - Lost communication with door module
C102B - Right rear wheel speed circuit
C1219 - Steering angle sensor erratic performance
C2205 - Steering angle sensor internal
U0209 - Lost communication with memory seat
U1158 - Lost communication with Sat. video receiver
U0196 - Lost communication with vehicle entertainment module
U0010 - CAN interior bus

I cleared them and started the Jeep. It instantly re-tripped U0249, U0415, and C102B.

I can rule out the battery, since it is new. Now I do have a Lockpick installed so that may explain some of the entertainment codes... but would it also trip the other interior related stuff?

What's with all the steering codes???

I still love this thing... even with Chrysler bailing on me and the vibration..but this stuff is starting to scare me...

Going back a way... I had I similar rash of codes after it was at the dealer for a while... chalked it up to them running the battery dead... since all my memory stuff had to be reset and they normally don't even if you unhook the battery for a while.

__________________
Jeff

2010 Jeep Liberty Limited
josworth is offline   Reply With Quote Quick reply to this message
Unread 10-13-2014, 09:11 AM   #2
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,463
Hopefully someone with more experience will chime in, but here is my two cents.
When a vehicle throws a code, it seems to be rare that it's only one. One code seems to always trigger others.
I've had weird codes thrown before, maybe one or two of the same as you.
The weirdest one I've had was something about the airbag if I remember correctly.
I'd check out the wheel speed sensor, since you seem to know it's going bad, the other stuff I'd give a once over and play it safe for a while.
__________________
OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 10-13-2014, 01:52 PM   #3
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron, Ohio (OH)
Posts: 423
I reset the connector once again... Funny thing is the dealer replaced the speed sensor and wire, or so they say, less than a year ago. This is the second time I have pulled the connector to find the seal all the way at the end. Also, the conduit and tape end with just the wires loose. I think they may have done it by cutting off wires and now there is a slight tug... just enough to loosen the seal.. then rain get in and shorts it..

It drove today fine with no lights. I will see when it rains heavy tomorrow.

Looks like another "dealer" repair that if I want it done right, I have to do it myself...

I think, since they had the front end apart replacing the front half shafts, I will need to check wiring to the steering sensor as well...

I try so hard to be nice and understanding.. but really get why they get horrible nicknames..
__________________
Jeff

2010 Jeep Liberty Limited
josworth is offline   Reply With Quote Quick reply to this message
Unread 02-19-2015, 05:50 PM   #4
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron, Ohio (OH)
Posts: 423
More code soup.

And the speed sensor is acting up. Figures I have to drive to Jersey tomorrow afternoon and we are due for record lows. So, bought two mopar connector pigtails for the rear sensors and have an appointment with a trusted shop to install them. I'm done with the resetting the loose connectors. Figures it's just to damn cold to be laying under it in the garage. So I figure labor will be around $100 and the connector pigtails ran $30 each.... so $160 for a repair that who knows if it will last and if it does should have been done right the first time. Like I said in another post... I am really getting sick and tired of this thing.
__________________
Jeff

2010 Jeep Liberty Limited
josworth is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.