Check Engine Light P0456 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Check Engine Light P0456

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits BLACK FRIDAY SPECIALS!! You asked, we deliver!Rough Country Lift Kits and Parts!

Reply
Unread 09-29-2010, 06:03 AM   #1
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Check Engine Light P0456

So got my first CEL since i bought it 2 1/2 Years ago. P0456. After reading its referring to a small leak in the Evaporation System. First everyone says to check the Gas Cap which i turned off the engine, Took the cap off, put it back on and made sure it clicked a few times. The cap is a Mopar Locking Cap that I've had since i bought the Jeep. After removing the cap and putting it back on the light is still on after i drove about 22 miles to work. I don't know how long it takes for the code to disappear if that was the issue but the light is still on. So basically I'm going to hope its off when i leave work today and if not ill put my girlfriends Locking Mopar Cap from her Patriot on mine and see what happens. Any other suggestions to look for?

__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote Quick reply to this message
Unread 09-29-2010, 01:18 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
There are 2 causes of PO456,I would swap caps to see if that helps,If not the there a small leak somewhere in the EVAP:
  • Fuel tank cap is damaged, loose or the wrong part number
  • Small leak present somewhere in the EVAP system
Here is how to reset your code:

To reset your engine codes:
Remove the negative terminal of your battery (10mm wrench).

Turn your ignition key to START and hold it there for about 15 seconds.
Turn your ignition key to OFF and remove it.
Connect the negative terminal of your battery.
Start but do not hit the throttle. Idle for about 10/15 seconds then turn off.
Restart the truck and drive as usual. It will take at least 12 starts and 48 miles to fully retune the computer. Hard Codes leave a shaddow for 40 full cold starts.
richd is offline   Reply With Quote Quick reply to this message
Unread 09-29-2010, 05:29 PM   #3
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
So i inspected the Evap Box and hoses and didnt see any holes or tears etc. BUT, i could smell gas from the Cap so i think its leaking. So i disconnected both battey terminals for 30 minutes and threw my original Gas Cap on that i found laying around and so far so good. Ill keep you guys updated over the next week. Wish me luck.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote Quick reply to this message
Unread 09-29-2010, 06:04 PM   #4
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Your doing it the right way,Good Luck
richd is offline   Reply With Quote Quick reply to this message
Unread 10-05-2010, 10:03 AM   #5
KUHawkhead
Registered User
2008 KK Liberty 
 
Join Date: Feb 2008
Location: McPherson Kansas
Posts: 122
We had the same thing happen on our 08 this past week. Had a mechanic friend of mine check and reset the light. He told me that it would reset itself if it's nothing out of the ordinary within a week on its own.
KUHawkhead is offline   Reply With Quote Quick reply to this message
Unread 10-17-2011, 05:18 PM   #6
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
i just got this code today did yours dissapear after you changed the gas caps?
my jeep had the gas tank replaced under warranty and it was at the dealership for spider gear replacement over a week ago. since the evap canister is right in the proximity, i wonder if these things are related....
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 10-18-2011, 07:37 AM   #7
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 944
Yup hasnt happened since.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote Quick reply to this message
Unread 10-18-2011, 09:32 AM   #8
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
interesting... i wonder if my gas cap is bad or its just my lack and one of the hoses got a crack...
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 10-20-2011, 10:57 AM   #9
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
well the light dissapeared 2 days after. i guess it was the cap, i removed it for inspection, no cracks, put it back in tight and it dissapeared. i was about to swap the gascapts between the liberty and the rubicon but decided to start n check first and it was gone! yey!
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 10-20-2011, 12:13 PM   #10
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,141
Locking gas caps are known for leaking and don't do much good when a $5 tool is out there to easily remove them.

For $12 for a new gas cap it's just a good idea to change every year or at least every 2 years.
__________________
'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline   Reply With Quote Quick reply to this message
Unread 10-20-2011, 01:03 PM   #11
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
neither jeep has a locking one, just regular OEM caps that came with both cars. rubber seal seems to be fine i think i just didnt tighten it up enough after last refill.
__________________
___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline   Reply With Quote Quick reply to this message
Unread 10-14-2014, 10:34 PM   #12
beherenow
Registered User
2009 KK Liberty 
 
Join Date: Jul 2009
Location: Mty Mexico
Posts: 94
so last friday the engine light came on... damm... just now i did the car key trick and the code back in the od came as P0456.... i still have the original 5 year gas cap... guess i"l hace to replace it and cross my fingers this gets resolved
beherenow is offline   Reply With Quote Quick reply to this message
Unread 10-15-2014, 05:05 AM   #13
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron, Ohio (OH)
Posts: 339
Helpful tip..... visual inspection is pretty worthless with emissions regulated gas caps. Similar to a radiator cap, they contain a pressure valve that wears out. If your state has emissions testing, the test center will have a cap pressure tester. In Ohio, our e-check station will check your cap for free.

Some auto parts stores will test them as well.
__________________
Jeff

2010 Jeep Liberty Limited
josworth is offline   Reply With Quote Quick reply to this message
Unread 10-20-2014, 12:13 AM   #14
beherenow
Registered User
2009 KK Liberty 
 
Join Date: Jul 2009
Location: Mty Mexico
Posts: 94
changend my cap and the msg went away, yes!
beherenow is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.