Change oil message - JeepForum.com
 
LinkBack Thread Tools
post #1 of 4 Old 12-16-2013, 10:23 AM Thread Starter
rangerr47
Registered User
2012 KK Liberty 
 
Join Date: Aug 2011
Location: Dallas
Posts: 182
Change oil message

The last oil change I did myself, its been about 2500 miles 5w 20 Valvoline Synthetic if it matters, with a Napa gold filter.

It got cold here in Texas not long ago and after the jeep sat in my garage for 4 straight days of ice and sub freezing temps...the change oil message pops up when I start up. It does it every time I start up. I checked and the level is fine, looks ok as well, as in not black and nasty looking.

What I want to know is if this is because its been cold that its doing this? Was I suppose to reset something when I changed it last? I have never seen this message, I just always changed it when miles were up. So what makes it trip to tell you its time to change your oil? I just dont want it to cause problems.

rangerr47 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-16-2013, 11:29 AM
nws2002
Registered User
2011 KK Liberty 
 
Join Date: Apr 2013
Location: Tulsa
Posts: 13
It's easy to reset. Just turn the key to on, not start just on, and push slowly on the gas pedal three times, then turn to off.

The engine computer calculates oil changes based on driving habits and other factors. It does not have a sensor that directly looks at the oil.
nws2002 is offline  
post #3 of 4 Old 12-16-2013, 11:51 AM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
I actually remembered for the first time to reset the message when I did my oil the other day.
Not sure how accurate it is, just don't be a dummy and change it when it's needed.
I was also a bit worried the first time I saw that message after changing my oil.

OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline  
post #4 of 4 Old 12-17-2013, 07:31 PM
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst
Posts: 1,554
I find that it pops up whenever you change your oil and don't reset it. Not sure why, I also noticed some places don't reset it unless you have the message popping up(for those of you that don't change your own oil).

2011 KK - Skyslider - JBA Adjust-A-Strut - OME 731 - Bilstein Shocks - JBA UCA- 245/75-16 Duratracs
Bmxer524 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome