Car in drive, foot off the brake and car doesnt move - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Car in drive, foot off the brake and car doesnt move

Trick Tabs - NalinMFG.comECGS American Made Stub ShaftsDisc Brake Kits from ECGS

Reply
Unread 05-02-2011, 01:54 PM   #1
jonny79ny
Registered User
2011 KK Liberty 
 
Join Date: May 2008
Location: New York
Posts: 10
Car in drive, foot off the brake and car doesnt move

Just bought a new 2011 liberty sport and realize that when you are in drive and take your foot off the brake the car stands still when you are stopped. Every other car I have driven would start moving a bit when releasing the brake but this one goes no where. I'm wondering if there is something wrong with my Liberty or is everyone else experiencing this too? Can it be something to do with that hill decent or something?

jonny79ny is offline   Reply With Quote
Unread 05-02-2011, 06:02 PM   #2
BloodyShadow23
Registered User
2008 KK Liberty 
 
Join Date: Mar 2011
Location: Highlands Ranch, Colorado
Posts: 116
If anything it would be if you are on an incline, not a decline. But apart from that I don't know.
__________________
2008 Liberty Sport - Chrome Grill, K&N CAI,
BloodyShadow23 is offline   Reply With Quote
Unread 05-02-2011, 06:46 PM   #3
ds6310
Registered User
2008 KK Liberty 
 
Join Date: Feb 2011
Location: Pittsburgh, PA
Posts: 62
Heavy vehicle with a low idle speed, I'll try it in my Lib but I think it's normal..
ds6310 is offline   Reply With Quote
Unread 05-02-2011, 09:23 PM   #4
Nanigai
Registered User
2014 WK 
 
Join Date: Feb 2011
Location: Townsville, Queensland
Posts: 6
I believe it;s normal also. Probably to do with the hill start control.
Cheers
Nanigai is offline   Reply With Quote
Unread 05-03-2011, 07:20 AM   #5
jsburton84
Registered User
2008 KK Liberty 
 
Join Date: Jun 2010
Posts: 170
I wouldn't worry about it. Mine behaves exactly the same. The only time it really bugs me is when waiting in line at toll booths and stuff because instead of just letting off the brake I have to gas, brake, gas, break.
__________________
2008 KK sport 4x4
1998 XJ sport 4x4 (sold)
jsburton84 is offline   Reply With Quote
Unread 05-03-2011, 11:51 AM   #6
sloan74
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2010
Location: Charlotte NC
Posts: 606
normal
sloan74 is offline   Reply With Quote
Unread 05-10-2011, 01:22 AM   #7
Telerock
Registered User
2010 KK Liberty 
 
Join Date: May 2011
Location: Boulder, Colorado
Posts: 11
Yup, same here. Heavy vehicle with heavy torque engine as others have said.
Telerock is offline   Reply With Quote
Unread 05-10-2011, 02:50 PM   #8
r1967a
Registered User
1999 WJ 
 
Join Date: Feb 2010
Location: el paso
Posts: 104
ours does it too..normal
r1967a is offline   Reply With Quote
Unread 05-11-2011, 07:19 AM   #9
teknight
Registered User
2011 KK Liberty 
 
Join Date: Feb 2011
Location: Tempe, AZ
Posts: 22
I've noticed it as well. I attributed it to the hill assist but I don't really know much about that feature. I need to research.
__________________
2011 Jeep Liberty Limited
teknight is offline   Reply With Quote
Unread 05-11-2011, 07:41 AM   #10
jonny79ny
Registered User
2011 KK Liberty 
 
Join Date: May 2008
Location: New York
Posts: 10
I see the general consensus is that it normal. Thank you everyone for your replies. I feel better now knowing my new car is not defective.
jonny79ny is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.