Can someone please help me - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 06-13-2013, 12:28 AM Thread Starter
redncfootball
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Posts: 55
Can someone please help me

I am constantly having the abs, esp, traction control and service 4wd light come on while driving and the brake pulses sometimes but they go away after i turn the car off and then turn it back on. I have to get it fixed and have been trying to find an answer and i cant find any. Im trying to avoid the stealership and it isnt working. Anyone have a resolution to this?

Attached Thumbnails
image-785779739.jpg  
redncfootball is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-13-2013, 12:36 AM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,393
How about some info? Year? Lifted? and anything else you can think of.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline  
post #3 of 8 Old 06-13-2013, 12:48 AM Thread Starter
redncfootball
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Posts: 55
Quote:
Originally Posted by tjkj2002
How about some info? Year? Lifted? and anything else you can think of.
2010 liberty limited, about 60k, no lift nothing i can think of that would have caused this. I bought the car used about a year ago and have babied it
redncfootball is offline  
post #4 of 8 Old 06-14-2013, 10:23 AM
Slayers
Registered User
2008 KK Liberty 
 
Join Date: Sep 2011
Location: Dearborn Heights
Posts: 27
The ABS and traction control lights could be the sign of a bad speed sensor.

I am not sure if that could also be causing the 4x4 light to turn on also but there is always a chance.

Your best bet would be to find someone with a scaner and have them check for codes everytime that turns on it should throw and store a code in the PCM
Slayers is offline  
post #5 of 8 Old 06-14-2013, 10:35 AM
99JeepGC47
Registered User
2008 KK Liberty 
 
Join Date: Jul 2010
Location: Sumter
Posts: 199
I will have to have mine checked. It started this today.
99JeepGC47 is offline  
post #6 of 8 Old 06-14-2013, 02:56 PM
Edwardkain
Registered User
2008 KK Liberty 
 
Join Date: Feb 2012
Location: Baghdad
Posts: 17
hey buddy am having the same, I can tell you how its happening in your vehicle, try this steer your steering wheel to any end till you can turn no more and drive the car, you will have a possibility of these lights to come out on, the cause is either the front ball joints in the lower and upper controlling arms or the steering wheel assembly is loose a little bit or unbalanced wheels. in any of these conditions the car will read a problem with the car alignment and will shut down these services right away because if it keep running they will steer the vehicle in wrong direction automatically and will not allow you to steer up ahead and this will defiantly cause an accident so this thing is for your own safety

So First go and check your wheels alignment and make sure that the steering wheel and the tires are at 0 degree, and than check that there is no loose in the steering wheel assembly and the end tie road are exactly fit and tightened well.

I hope it will help
Edwardkain is offline  
post #7 of 8 Old 06-17-2013, 10:50 PM Thread Starter
redncfootball
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Posts: 55
I had the code read and they said it was the driver side rear speed sensor. I took it out cleaned it and have not had the problem yet for about 50miles. Crossing my fingers
redncfootball is offline  
post #8 of 8 Old 06-18-2013, 09:07 AM
heiliges
Registered User
2012 KK Liberty 
 
Join Date: May 2013
Location: Jacksonville
Posts: 68
sounds like you fixed it
heiliges is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome