Broken cargo bin clip - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 02-27-2013, 01:45 PM Thread Starter
nike4674
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Union
Posts: 37
Broken cargo bin clip

I might have broke or popped off the one clip that holds the cargo tray down. Now it looks like I have to remove the whole floor and side panels to fix it. Any ideas?

nike4674 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-27-2013, 05:02 PM
eoerikson3
Registered User
2011 KK Liberty 
 
Join Date: Dec 2011
Location: Pawtucket
Posts: 360
I think I read on LOST that that is indeed the case. It is a bit of a PITA. Have fun with it.

Sent from my iPhone using JeepForum

-Oscar
Chrome may not get you home, but sometimes it looks nice.
2011 Liberty Sport
Added tow hitch, tow hooks, skid plates, foglight kit and headlight masks, remote start, chrome steps, and Cooper Discoverer A/T3 235/75R16.
Stuff for sale
eoerikson3 is offline  
post #3 of 6 Old 03-04-2013, 06:33 AM
Eagle112199
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2012
Location: Sterling
Posts: 76
No I had one break on me too. The clip pulls out of the floor (ended up breaking the plastic clip completly and pushed the clip down through the car and out the bottom.) Ordered a new clip from dealer (around $50 a pop) and they pushed right in without problems. Only issue I had was the new one didn't have a loophole for a finger - it was a solid piece. Ended up ordering two to match and the dealer cut me a deal because having to order a second one that wasn't broken. Not sure if this was a design change as production went on, but I have an 08 and it could have changed. To be honest I like the more solid tab because the loop I felt would break if too much pressure was applied. Check it out.

Hope this helps!

Jeep: It's a passion, not an obsession.

2010 JK Wrangler 2-Door
Soft Top
Eagle112199 is offline  
post #4 of 6 Old 03-05-2013, 08:02 PM Thread Starter
nike4674
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Union
Posts: 37
Quote:
Originally Posted by Eagle112199 View Post
No I had one break on me too. The clip pulls out of the floor (ended up breaking the plastic clip completly and pushed the clip down through the car and out the bottom.) Ordered a new clip from dealer (around $50 a pop) and they pushed right in without problems. Only issue I had was the new one didn't have a loophole for a finger - it was a solid piece. Ended up ordering two to match and the dealer cut me a deal because having to order a second one that wasn't broken. Not sure if this was a design change as production went on, but I have an 08 and it could have changed. To be honest I like the more solid tab because the loop I felt would break if too much pressure was applied. Check it out.

Hope this helps!
What do they look like? I Should just rip the old ones out?
nike4674 is offline  
post #5 of 6 Old 03-11-2013, 07:43 AM
Eagle112199
Registered User
2010 JK Wrangler 
 
Join Date: Jan 2012
Location: Sterling
Posts: 76
Yeah I just ripped them out - whole unit, spring and all is replaced when you order the new part. Look under the tab you will see a square insert, that needs to be pulled out and replaced.

Jeep: It's a passion, not an obsession.

2010 JK Wrangler 2-Door
Soft Top
Eagle112199 is offline  
post #6 of 6 Old 11-20-2013, 07:31 PM Thread Starter
nike4674
Registered User
2011 KK Liberty 
 
Join Date: Jul 2011
Location: Union
Posts: 37
Jeep fixed it for free.
nike4674 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome