Blower vent control question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Blower vent control question

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsJK Front Lower Adjustable Control Arms!

Reply
Unread 01-17-2013, 09:51 AM   #1
wrathwielder
Registered User
2011 KK Liberty 
 
Join Date: Sep 2011
Location: Bloomington, MN
Posts: 15
Blower vent control question

Hi all!

Can someone with a 2011 Liberty do a small test for me?

When I set my blower "vent" control to 12:00, the pic indicates it should blow only at your feet...mine annoyingly ALSO blows out the defrost.

I would think it should be feet only and then as I rotate clockwise to the other settings it would gradually start adding the defrost until it was totally defrost...doesn't seem to work that way (and even 1 small click left (11:00) shuts off defrost but adds the front vents which I would expect - I just don't have feet only)

Just wondering if there's something wrong with my vent control, or if it's just doing what it's supposed to be doing...?

It just bugs me that my face always has to get heat when sometimes I want it all directed at my feet

Thanks everyone!

-Greg

wrathwielder is offline   Reply With Quote
Unread 01-17-2013, 12:46 PM   #2
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst, NY
Posts: 941
My 11 does it too. It's rather annoying, but I just got used to it.
Bmxer524 is offline   Reply With Quote
Unread 01-17-2013, 04:17 PM   #3
wrathwielder
Registered User
2011 KK Liberty 
 
Join Date: Sep 2011
Location: Bloomington, MN
Posts: 15
Quote:
Originally Posted by Bmxer524 View Post
My 11 does it too. It's rather annoying, but I just got used to it.
Hi!

I got a response in another forum:
"My 2011 is a Sport model. I have no problems with having the blower operating as desired. It's still under warranty? Take it in if it is."

Strange! After I saw your post I was going to just let it go as status quo until I saw his post...now I'm not so sure!

Is yours a Sport? If not, maybe it's a non-sport only prob...?

Have to see if anyone else reports in

Thanks!

-greg
wrathwielder is offline   Reply With Quote
Unread 01-17-2013, 06:08 PM   #4
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst, NY
Posts: 941
Mine is a Sport. The only options I basically have are 4x4 and the skyslider lol
Bmxer524 is offline   Reply With Quote
Unread 01-18-2013, 02:28 PM   #5
rescue575
Senior Member
 
rescue575's Avatar
2011 KK Liberty 
 
Join Date: Feb 2012
Location: Franklin Square, NY
Posts: 853
I have a sport. At 12:00 it blows out feet and a very little amount of air comes out defroster vents. Not enough for me to even notice unless I have my hand against the vent until I start moving knob do defroster.

Sent from my iPhone using JeepForum
__________________
2011 Liberty Sport
2 KC Slimlite[RIGHT] 130 Watt Long Range on JK Bar
TMS Aluminum Roof Rack Cross Bars
Cobra 75, Firestik Door Jam Mount, HD Spring, 2Ft Firestik
Dunlop Fierce Attitude M/T
rescue575 is offline   Reply With Quote
Unread 01-20-2013, 07:22 PM   #6
kxeddiexp
Registered User
 
Join Date: Dec 2011
Location: queens, New York
Posts: 49
Hey thanks for posting this thread.

I believe its normal unfortunately with the liberty.
Mine does the exact same thing. I might as well have wrote this thread myself

I pulled apart the center console and unplugged the blend door controls and checked if something was loose.

It was all fine. Im assuming that its a flaw since others are saying the same thing. Sucks! I know

Let me know if u ever get it fixed
kxeddiexp is offline   Reply With Quote
Unread 01-21-2013, 08:13 AM   #7
tbenson
Registered User
 
Join Date: Feb 2012
Location: , ohio
Posts: 22
Mine does the same, and during the Hot days, it continues to blow heat out of the vents when everything is in the off position.
tbenson is offline   Reply With Quote
Unread 01-21-2013, 08:21 AM   #8
rescue575
Senior Member
 
rescue575's Avatar
2011 KK Liberty 
 
Join Date: Feb 2012
Location: Franklin Square, NY
Posts: 853
Quote:
Originally Posted by tbenson View Post
Mine does the same, and during the Hot days, it continues to blow heat out of the vents when everything is in the off position.
Yes, that too!!!! lol
__________________
2011 Liberty Sport
2 KC Slimlite[RIGHT] 130 Watt Long Range on JK Bar
TMS Aluminum Roof Rack Cross Bars
Cobra 75, Firestik Door Jam Mount, HD Spring, 2Ft Firestik
Dunlop Fierce Attitude M/T
rescue575 is offline   Reply With Quote
Unread 01-23-2013, 10:04 PM   #9
wrathwielder
Registered User
2011 KK Liberty 
 
Join Date: Sep 2011
Location: Bloomington, MN
Posts: 15
Thanks everyone for the input! Sad to hear that so many have this problem though

I did get a response in another forum where it works as it SHOULD with no air coming out of the defrost (like what you saw rescue575)

Mine definitely has a lot of air coming out when set to feet only (and the blower on high).
What's interesting is that the 12:00 and 1:00 positions are EXACTLY the same...nothing changes in the floor or defrost vents at all - why even HAVE 2 different positions if they're the same?

I'm bringing it in Friday to have the dealer look at it - the fact that those 2 positions are exactly the same gives me added incentive to press them on this

I'll report back what they say - I'm getting tired of having the heat blowing in my face when my feet need it more (was -12 here in MN yesterday!)

Thanks everyone!

-Greg
wrathwielder is offline   Reply With Quote
Unread 01-24-2013, 03:43 AM   #10
rescue575
Senior Member
 
rescue575's Avatar
2011 KK Liberty 
 
Join Date: Feb 2012
Location: Franklin Square, NY
Posts: 853
Good luck. Hope svc finds a remedy.

Sent from my iPhone using JeepForum
__________________
2011 Liberty Sport
2 KC Slimlite[RIGHT] 130 Watt Long Range on JK Bar
TMS Aluminum Roof Rack Cross Bars
Cobra 75, Firestik Door Jam Mount, HD Spring, 2Ft Firestik
Dunlop Fierce Attitude M/T
rescue575 is offline   Reply With Quote
Unread 01-24-2013, 09:38 PM   #11
kxeddiexp
Registered User
 
Join Date: Dec 2011
Location: queens, New York
Posts: 49
Yea good luck. Be sure to let us know what they say. Because i have the same prob. I dread waiting for hours for them to get to my car and then wait more for them to look at it.

Thanks
kxeddiexp is offline   Reply With Quote
Unread 01-27-2013, 04:56 PM   #12
wrathwielder
Registered User
2011 KK Liberty 
 
Join Date: Sep 2011
Location: Bloomington, MN
Posts: 15
Quote:
Originally Posted by kxeddiexp View Post
Yea good luck. Be sure to let us know what they say. Because i have the same prob. I dread waiting for hours for them to get to my car and then wait more for them to look at it.

Thanks
OK...took the Jeep to the dealer and showed him the problem.

They looked it over and told me they needed to replace the HVAC "box" which is a 6-hour procedure. I asked if it could possibly just be the switch, but he said there is a controller that is part of the HVAC unit and it's what tells the vents to open/close for each switch setting.

SO, I'm dropping it off Monday morning so they can have their way with it.
I guess the dash has to come out. Hopefully they don't mess up my Lockpick and camera install as I have it all done so Purdy and everything!

I'll send an update after I get it back!

-Greg
wrathwielder is offline   Reply With Quote
Unread 01-28-2013, 04:20 PM   #13
wrathwielder
Registered User
2011 KK Liberty 
 
Join Date: Sep 2011
Location: Bloomington, MN
Posts: 15
meh...no joy

I picked up the truck and they informed me that they didn't have to replace the entire HVAC box assembly, but only an actuator/motor and a distribution directional control or some such thing...

The guy said there was now a "noticeable difference" between the 12:00 feet only setting and the next one...NOPE!

I detected a barely noticeable change in the air blowing when I went from 12:00 to one click (half-setting) to the right, which I guess is better than it was, but hardly the "noticeable difference" they mentioned.

I guess the only thing I can do now is go back to the dealer and test a couple of their Liberty's and hope they work differently than mine so I have proof right in front of them.

I will keep you posted so you all don't lose sleep over my dilemma


-Greg
wrathwielder is offline   Reply With Quote
Unread 01-28-2013, 09:15 PM   #14
kxeddiexp
Registered User
 
Join Date: Dec 2011
Location: queens, New York
Posts: 49
Quote:
Originally Posted by wrathwielder
meh...no joy

I picked up the truck and they informed me that they didn't have to replace the entire HVAC box assembly, but only an actuator/motor and a distribution directional control or some such thing...

The guy said there was now a "noticeable difference" between the 12:00 feet only setting and the next one...NOPE!

I detected a barely noticeable change in the air blowing when I went from 12:00 to one click (half-setting) to the right, which I guess is better than it was, but hardly the "noticeable difference" they mentioned.

I guess the only thing I can do now is go back to the dealer and test a couple of their Liberty's and hope they work differently than mine so I have proof right in front of them.

I will keep you posted so you all don't lose sleep over my dilemma

-Greg
Cool! Thanks for the update. I was going to take it in to the dealer tomorrow for them to look at it again. I had the same problem before and they said they fixed it but no difference! I wasted so much time at the dealership and on the phone with "chrysler customer care". Looking back this jeep brand has been giving so many people so many problems. Seems like they just dont care.

Eitherway thanks for the update. Please do keep us posted. Thanks!
kxeddiexp is offline   Reply With Quote
Unread 02-01-2013, 10:42 AM   #15
wrathwielder
Registered User
2011 KK Liberty 
 
Join Date: Sep 2011
Location: Bloomington, MN
Posts: 15
Vent-a-palooza update...

Went to the dealer and did a "paper test" on a 2012 Liberty they had there...
I just stuck a piece of 8.5x11 paper over the right defrost went (portrait orientation and tucked into the base of the windshield so it was laying across the vent)
I turned the blower on full and set the control to 12:00 (feet only) and the paper never lifted off the dash, although there was still a little air coming from the vent.
When I do this on MY truck, the paper lifts totally off the dash and hits the windshield.
So, FINALLY the dealer got to see what my issue is.
I showed him that there was no difference between 12:00 and 1:00 on the switch, and that it appeared that both positions were doing the 1:00 setting.

I suggested that maybe it was just a bad switch (which I suggested the FIRST time I brought it in but they didn't buy it). He said that would be the best place to start so he ordered a new 3-switch replacement panel.
I'll bring it in Monday and get it installed and let you know what happens!

-Greg
wrathwielder is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.