All of your O2 sensors go hay wire? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > All of your O2 sensors go hay wire?

Component speaker deal for your dash - NalinMFGJK Vent Covers - NalinMFGTJ 5.25" Speaker Adapters - NalinMFG

Reply
Unread 10-29-2010, 02:22 AM   #1
Lafaso870
Junior Member
 
Join Date: Sep 2010
Location: newyork
Posts: 24
All of your O2 sensors go hay wire?

Have any of y'all had this problem? My wife's 09 KK had a check engine light so I took it to the dealership and was amazed to find out error messages on 4 O2 sensors. Its covered under warranty so no worries, but they think the module when bad. They asked if I had driven it through water which of course I haven't since its a 2WD and hers. Hmm interesting...

Lafaso870 is offline   Reply With Quote
Unread 10-29-2010, 04:48 AM   #2
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
first time Ive heard of a KK having all 4 O2s go bad.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 10-29-2010, 11:46 AM   #3
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
When you have a code showing all 4 O2 sensors bad,its not the sensors but a problem with the wiring harness or a bad PCM.
richd is offline   Reply With Quote
Unread 10-29-2010, 02:18 PM   #4
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Quote:
Originally Posted by richd View Post
When you have a code showing all 4 O2 sensors bad,its not the sensors but a problem with the wiring harness or a bad PCM.
Absolutely! I am thinking moisture is the culprit
__________________
2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.