airbag indicator always on - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 11-01-2010, 09:12 AM Thread Starter
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
airbag indicator always on

so i got into the car this morning and was greeted by the flat tire and airbag system indicator on along with the pass airbag off indicator constantly lit as well.
not sure as to what could have caused this..
the only avail appt is in 10 days and im concerned about the safety of driving the jeep now. any of you guys had to deal with this?


___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-01-2010, 10:35 AM
otlip
Registered User
 
Join Date: Apr 2010
Location: nj
Posts: 109
Try disconnecting the battery cable and reconnecting. This seems to solve many of the computers problems. like a cold reboot!
otlip is offline  
post #3 of 8 Old 11-01-2010, 12:02 PM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
If the light is always on then there is probably something wrong, most likely a sensor and since it involves the safety of you and your Jeep i would have it looked at ASAP

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
post #4 of 8 Old 11-02-2010, 10:20 AM Thread Starter
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
i will def check it out, but the appt is only on nov 11
the thing is, i think its time/temp related. once i got into the car after work yesterday, the light was gone while temp was around 52 degrees. this morning temp was 39 degrees and the light was back, i wonder if its going to light up today after 6...

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
post #5 of 8 Old 01-16-2011, 09:48 AM Thread Starter
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
well the jeep is @ the dealer for a week already, hopefully it will be fixed by tuesday.
i brought it there last monday, for the tank overfilling problem and the airbag problem. they said they replaced some tube, dont remember the PN to check what actually was replaced and "recalibrated" the weight sensors in the seats, since thats what was causing the airbag light on. when i suggested that the problem is temperature dependent they dismissed it. guess what, when i came back to pick up the car both lights were on! i brought it to their attention and now they beleived me that there might be a problem with the sensors and they might need to be replaced. they called some star dept, that told them the car is safe to drive, i still refused to pick it up and left it there. that was last tuesday. on fri they called said they got 4 sensors and now missing the wiring harness. im lost as to why would u need a wiring harness when you are changing the sensors.. unless of course they messed the original one up.... im getting a lil upset over this issue. i love the jeep and i want to keep it! oh and this new delaership that i went to in manhattan is by far MUCH better then the brooklyn one i used to go to. bunch of shady guys doing i dont know what with them cars.

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
post #6 of 8 Old 01-21-2011, 06:48 PM Thread Starter
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
im not sure to laugh or to cry at this point, but when i went to pick up the car today, the light was still on!!!
i could not beleive it! so i didnt pick up the car and took the loaner grand cherokee instead. i really hope they are going to fix it next week. im starting to miss the car...

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
post #7 of 8 Old 01-26-2011, 03:29 PM Thread Starter
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
finally i got my car back! things changed! filler neck, airbag system wiring harness, weight sensors in the seats and strain sensor somwehere, not sure where! now the light is gone!!
i hope forever!

___________________________
2008 KK limited 4x4. Inferno Red
2009 JK Rubicon. Black
2004 UCF31. Black
2001 EM2. Inca pearl
2012 UD Limited. Royal Gray
VMF is offline  
post #8 of 8 Old 01-26-2011, 04:35 PM
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
Good to hear

---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Brake Service Indicator?? stillwater867 KK Liberty Forum 22 07-01-2013 03:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome