post #1 of Old 12-27-2010, 03:19 PM Thread Starter
dlaron
Registered User
 
Join Date: Dec 2010
Location: Portland
Posts: 10
AC/Heater Climate Control Fan not blowing

New to forum. Black 2008 Liberty Limited. Recently noticed the AC doesn't come on and fan doesn't blow. However, when I use remote start, fan will come on and blow hot/warm air. when I unlock jeep, insert key to "on" position to drive off...heater blower shuts off.

I read a post about checking fuses. I looked in the manual and thought it could be Fuse #24? or Fuse #1? ????

Any Help would be awesome!
Thanks!
DLaron

dlaron is offline  
post #2 of Old 12-27-2010, 07:27 PM
Dave_B
Registered User
2008 KK Liberty 
 
Join Date: Dec 2007
Location: mlps
Posts: 229
I would guess you have Auto Climate control just let the engine warm up and it will come on, or take it out of auto.

Dave

Lovin' my CARBON FOOT PRINT!
Dave_B is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
can i upgrade from no audio control on steering wheel to audio controls? rvicere KK Liberty Forum 3 05-17-2012 08:51 AM
Wireless Control Module Location dwrodgers52 KK Liberty Forum 9 04-26-2012 10:50 AM
Heater Problems T1NGNR KK Liberty Forum 1 12-06-2010 10:12 AM
hot air blowing out of vents ColdCase KK Liberty Forum 1 09-15-2010 12:11 PM
How effective is the KK's Trailer Sway Control? LibertyHopeful KK Liberty Forum 3 06-23-2010 08:35 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome