2012 Liberty and Travel Trailers? - Page 5 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2012 Liberty and Travel Trailers?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsWant to be able to SEE? DOT Approved Headlights for under

Reply
Unread 06-27-2013, 01:16 PM   #61
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
Did your Jeep come with the towing package, and how far did you tow before the problem showed itself?

Paws4It is offline   Reply With Quote Quick reply to this message
Unread 06-28-2013, 07:01 AM   #62
RKK
Registered User
2012 KK Liberty 
 
Join Date: Apr 2013
Location: Ashburn, Virginia
Posts: 39
Quote:
Originally Posted by mswebb
Just finishing at the dealership now. Had the daytime running lights turned on and they programmed the computer to realize there is a towing package installed. The towing program should keep the systems from freaking out with the variable pulls and sways from the trailer.

Will let you all know if this fixes the issue.

Sent from AutoGuide.com App
What was the $ that dealer charged to reprogram?
RKK is offline   Reply With Quote Quick reply to this message
Unread 06-29-2013, 09:37 AM   #63
mswebb
Registered User
 
Join Date: Apr 2013
Posts: 10
$60 Canadian. Not all dealerships are aware of this requirement as I had it serviced in the US and they didn't know what they were doing.


Sent from AutoGuide.com App
mswebb is offline   Reply With Quote Quick reply to this message
Unread 06-29-2013, 09:39 AM   #64
mswebb
Registered User
 
Join Date: Apr 2013
Posts: 10
Towed the big trailer to the cottage which is a 3 hour with mostly moderate hills and a couple big ones. No problems and the lights stayed off.


Sent from AutoGuide.com App
mswebb is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 11:05 AM   #65
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
This is what we got, and Avenger TT. My Jeep pulls it well, but now we are having issues with the traction control light coming on, and the 4 wheel drive light coming on. Something else too, but it slips my mind at the moment. No rhyme or reason for it, and not when the TT is on either.
I wonder if there's been any recalls?
avenger-1st-day-6-15-13-20130615_131705.jpg  
Paws4It is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 11:46 AM   #66
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 574
Quote:
Originally Posted by Paws4It View Post
This is what we got, and Avenger TT. My Jeep pulls it well, but now we are having issues with the traction control light coming on, and the 4 wheel drive light coming on. Something else too, but it slips my mind at the moment. No rhyme or reason for it, and not when the TT is on either.
I wonder if there's been any recalls?
what size tires are you running? Half the reason I regeared was because pulling our camper was killing my jeep.
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 11:49 AM   #67
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
Hi Ted. The ones that came on it, 245-20. Do you think that may be what's wrong?
Paws4It is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 11:53 AM   #68
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 574
Quote:
Originally Posted by Paws4It View Post
Hi Ted. The ones that came on it, 245-20. Do you think that may be what's wrong?
You should be fine if those were the same size as the sticker says, mine came with 225/75-16. I went to 245/75-16 and it turned into a dog with the esp tripping all of the time.it's better now :-)
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 11:53 AM   #69
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
Quote:
Originally Posted by Ted15 View Post
what size tires are you running? Half the reason I regeared was because pulling our camper was killing my jeep.
What do camper do you tow? That's a pretty blue you have there.
Paws4It is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 11:55 AM   #70
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
Quote:
Originally Posted by Ted15 View Post
You should be fine if those were the same size as the sticker says, mine came with 225/75-16. I went to 245/75-16 and it turned into a dog with the esp tripping all of the time.it's better now :-)
Yeah, shoot, it came with those tires and the towing package.. Then we had the most problem getting someone to put a brake controller on it. It should be ok, in therory.. dont know what's wrong with her.
Paws4It is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 12:51 PM   #71
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 574
I tow a very heavy pop up, just over 1800 empty. I have all of the factory tire package except the mechanical fan. I didn't know the computer had to be programmed for towing. It seems to pull just fine now with the 4.10's and Trutracs.
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 01:50 PM   #72
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron, Ohio (OH)
Posts: 348
Quote:
Originally Posted by Paws4It View Post
This is what we got, and Avenger TT. My Jeep pulls it well, but now we are having issues with the traction control light coming on, and the 4 wheel drive light coming on. Something else too, but it slips my mind at the moment. No rhyme or reason for it, and not when the TT is on either.
I wonder if there's been any recalls?
Quote:
Originally Posted by Paws4It View Post
Yeah, shoot, it came with those tires and the towing package.. Then we had the most problem getting someone to put a brake controller on it. It should be ok, in therory.. dont know what's wrong with her.
The Traction Control, 4wd, and ABS systems are all interconnected. Have a dealer check the ABS system and wiring. My gut says that something is awry with the installation of the brake controller.
josworth is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 01:56 PM   #73
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
Quote:
Originally Posted by josworth View Post
The Traction Control, 4wd, and ABS systems are all interconnected. Have a dealer check the ABS system and wiring. My gut says that something is awry with the installation of the brake controller.
Oh my gosh, I hope not. It had a recall on it and they said it was fixed (that was before we had the controller put on) so I hope it is not the controller.. but thanks for the hint.. I will tell the dealer about it. With as much trouble as we had to get a controller on it better not be messed up!
Paws4It is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 01:57 PM   #74
Paws4It
Registered User
 
Join Date: Aug 2012
Location: , WV
Posts: 57
Quote:
Originally Posted by Ted15 View Post
I tow a very heavy pop up, just over 1800 empty. I have all of the factory tire package except the mechanical fan. I didn't know the computer had to be programmed for towing. It seems to pull just fine now with the 4.10's and Trutracs.
I know when you buy these vehicals with the tow package on you think they have what you need, but then find out that is not how it is!
I'm glad you got your's worked out.
Paws4It is offline   Reply With Quote Quick reply to this message
Unread 05-17-2014, 02:06 PM   #75
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron, Ohio (OH)
Posts: 348
Quote:
Originally Posted by Paws4It View Post
Oh my gosh, I hope not. It had a recall on it and they said it was fixed (that was before we had the controller put on) so I hope it is not the controller.. but thanks for the hint.. I will tell the dealer about it. With as much trouble as we had to get a controller on it better not be messed up!
Who installed the controller? Did they tap into the brake system electrically?

Modern vehicles are networked and their systems rely on a bunch of sensors. If additional things aren't done just right, it can create all kinds of mayhem.

I'm not saying the controller is messed up... I am thinking the controller or it's connections may be messing with the Jeep.

Took a friend and I a whole day of testing out a guy's Jaguar trying to figure out why it would randomly drop into Limp mode....

Ended up being the aftermarket remote start... Removed it and rewired the harness where it was tapped in and all issues went away...

Gone are the days of just splicing in stuff willy nilly......
josworth is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.