2010 Multiple Issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2010 Multiple Issues

Brand New! Quadratec LED Headlights!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 03-25-2013, 07:49 PM   #1
excelent1976
Registered User
 
Join Date: Jan 2013
Location: Tonawanda, NY
Posts: 9
2010 Multiple Issues

So far I've had my Jeep to the dealer 3 times for vibrations under warranty-still not right. Vibes at 60-70mph. Dealer replaced front and rear drive shafts. I put on new tires, balanced and re-balanced tires, aligned tires. Gave up on clock losing time issue. Hot plastic smell from mid level heat, not sure of that. Had extensive rust already on trans pan. Re painted it to keep from rusting through already! Had a 2007 Liberty-no problems with that. I like when I go to the dealer and they try to make up stuff and excuses. I'm ASE certified with 40 years' experience and currently teaching future auto techs; not gonna do the work that's covered under warranty ie: drivetrain....I'm just saying.

excelent1976 is offline   Reply With Quote
Unread 03-25-2013, 09:25 PM   #2
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,038
Just because the tires have been balanced,and zero out,does not mean they will not cause a vibration.Time to get them road force balanced by a tech that knows how to use the machine,will not be cheap.


As far as the trans pan rusting,try actually washing the under carriage,at least once every 2 weeks and yes even in the winter where it is most needed.
__________________
'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline   Reply With Quote
Unread 03-26-2013, 07:32 AM   #3
teckn9ne
Registered User
2010 KK Liberty 
 
Join Date: Jul 2011
Location: La Monte, Missouri
Posts: 166
My 2010 has no rust i heared east coast salt is bad but like tjkj clean it often.As for giving up on clock lossing time there is a TSB and it worked 4 me SERVICE BULLETIN NUMBER: 08-003-13
GROUP: Electrical
DATE: January 15, 2013

SUBJECT:
Clock In The Radio Loses Time

OVERVIEW:
This bulletin involves replacing the Wireless Control Module (WCM)/Sentry Key Remote Entry Module (SKREEM).

MODELS:
2009 - 2012 (JK) Wrangler
__________________
2010 Jeep Liberty Sport 4X4 Natural Green Pearl
Silverstar Headlights,Mopar Hitch,Mopar Tow Hook,Mopar Skids,Mopar Locking Lugs,Mopar Remote Start,Factory Sirius Radio,WeatherTech Digital Floor Mats,JCROffroad Stage 3 Sliders,Hankook DynaPro RF10 LT225/75/16,Diehard Platinum P1,JBA 5.5 UCA,OME HD,
teckn9ne is offline   Reply With Quote
Unread 03-26-2013, 07:34 AM   #4
teckn9ne
Registered User
2010 KK Liberty 
 
Join Date: Jul 2011
Location: La Monte, Missouri
Posts: 166
And u should try different dealership for the vibration.
__________________
2010 Jeep Liberty Sport 4X4 Natural Green Pearl
Silverstar Headlights,Mopar Hitch,Mopar Tow Hook,Mopar Skids,Mopar Locking Lugs,Mopar Remote Start,Factory Sirius Radio,WeatherTech Digital Floor Mats,JCROffroad Stage 3 Sliders,Hankook DynaPro RF10 LT225/75/16,Diehard Platinum P1,JBA 5.5 UCA,OME HD,
teckn9ne is offline   Reply With Quote
Unread 03-27-2013, 10:29 PM   #5
Poncherello
Moderator
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Paterson, New Jersey
Posts: 985
Quote:
Originally Posted by teckn9ne View Post
And u should try different dealership for the vibration.
The "stealer ship" ordered me the new replacement piece for the radio so it can actually tell time correctly. Just awaiting for it come in.

As far as the trans pan I will have to take a look under mine. I have been driving through a lot of salty water - overflow from the bay and salty roads

Just wondering if you bought your Lib new or second hand?
__________________
When you get knee-deep in a situation, floor it.
Poncherello is offline   Reply With Quote
Unread 04-02-2013, 02:40 PM   #6
excelent1976
Registered User
 
Join Date: Jan 2013
Location: Tonawanda, NY
Posts: 9
Quote:
Originally Posted by tjkj2002 View Post
Just because the tires have been balanced,and zero out,does not mean they will not cause a vibration.Time to get them road force balanced by a tech that knows how to use the machine,will not be cheap.


As far as the trans pan rusting,try actually washing the under carriage,at least once every 2 weeks and yes even in the winter where it is most needed.
I Road-Force Balanced them myself and checked for rim-runout. I do clean the undercarriage but the rust is from poor quality paint and/or metal. I've seen the underneath of a lot of cars and trucks from around here and most do not rust that fast. I'm happy to report the rest of the underneath is fine, just the trans pan was bad. Thanks for your reply.
excelent1976 is offline   Reply With Quote
Unread 04-02-2013, 02:47 PM   #7
excelent1976
Registered User
 
Join Date: Jan 2013
Location: Tonawanda, NY
Posts: 9
Quote:
Originally Posted by teckn9ne View Post
My 2010 has no rust i heared east coast salt is bad but like tjkj clean it often.As for giving up on clock lossing time there is a TSB and it worked 4 me SERVICE BULLETIN NUMBER: 08-003-13
GROUP: Electrical
DATE: January 15, 2013

SUBJECT:
Clock In The Radio Loses Time

OVERVIEW:
This bulletin involves replacing the Wireless Control Module (WCM)/Sentry Key Remote Entry Module (SKREEM).

MODELS:
2009 - 2012 (JK) Wrangler
Thanks for the reply! I loike the Pearl Green color you chose. Would like to see a picture. How do you like the floor mats? I see there's a fix now for the clock after 3 years. Thanks and good luck.
excelent1976 is offline   Reply With Quote
Unread 04-02-2013, 02:48 PM   #8
excelent1976
Registered User
 
Join Date: Jan 2013
Location: Tonawanda, NY
Posts: 9
Thanks for the reply! I loike the Pearl Green color you chose. Would like to see a picture. How do you like the floor mats? I see there's a fix now for the clock after 3 years. Thanks and good luck.
excelent1976 is offline   Reply With Quote
Unread 04-02-2013, 02:57 PM   #9
excelent1976
Registered User
 
Join Date: Jan 2013
Location: Tonawanda, NY
Posts: 9
Quote:
Originally Posted by Poncherello View Post
The "stealer ship" ordered me the new replacement piece for the radio so it can actually tell time correctly. Just awaiting for it come in.

As far as the trans pan I will have to take a look under mine. I have been driving through a lot of salty water - overflow from the bay and salty roads

Just wondering if you bought your Lib new or second hand?
Bought mine new after leasing a 2007. Got a good deal. I sanded and repainted my pan before it got any worse. Usually they rust that fast from poor quality metal.
excelent1976 is offline   Reply With Quote
Unread 04-02-2013, 02:57 PM   #10
excelent1976
Registered User
 
Join Date: Jan 2013
Location: Tonawanda, NY
Posts: 9
Bought mine new after leasing a 2007. Got a good deal. I sanded and repainted my pan before it got any worse. Usually they rust that fast from poor quality metal.
excelent1976 is offline   Reply With Quote
Unread 04-02-2013, 04:20 PM   #11
teckn9ne
Registered User
2010 KK Liberty 
 
Join Date: Jul 2011
Location: La Monte, Missouri
Posts: 166
The weather tech are great mats very pleased.My clock is dead on after a month and got pics in kk lift pics forum but here is pic after OME lift more in other forum
590995d1363971743-kk-lift-pictures-wp_000636.jpg  
__________________
2010 Jeep Liberty Sport 4X4 Natural Green Pearl
Silverstar Headlights,Mopar Hitch,Mopar Tow Hook,Mopar Skids,Mopar Locking Lugs,Mopar Remote Start,Factory Sirius Radio,WeatherTech Digital Floor Mats,JCROffroad Stage 3 Sliders,Hankook DynaPro RF10 LT225/75/16,Diehard Platinum P1,JBA 5.5 UCA,OME HD,
teckn9ne is offline   Reply With Quote
Unread 04-02-2013, 04:54 PM   #12
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 544
I have a problem with vibration also. I had the tires road force balanced which made a HUGE difference but the problem is still there. I've changed the tires twice. I've narrowed it down to a suspected broken intermediate axle shaft, probably took the cv axle with it by now, it really clunks. 31000 miles and both dealers I took it to flat out refused to touch it because it has larger tires and is lifted (OME). They wouldn't even take it apart to see if that was the problem. Anyway, getting a little off topic, sorry. Check the intermediate axle and see if that's it then make them fix it, unless you can get them to check it.
__________________
2010 Liberty KK Sport, deep water blue, weathertech in channel vent visors, weathertech digital floor mats, Detoures backbone winch mount w/smittybilt XRC 10 comp winch, rigid industries dually led lights on smittybilt fairhead mount, Rocklizard skink supersliders and Gecko safari rack, cobra cb w/48" firestick antenna, general grabber at2 245/75-16, OME heavy duty springs, OME shocks, about 3" - 3 1/2" of lift, Detoures Knucklebone spare tire and Jerry can mount, mopar skids, class 3 hitch w/7 pin wire harness, headlight covers, 4.10's and Detroit TruTracs F&R
Ted15 is offline   Reply With Quote
Unread 04-02-2013, 05:31 PM   #13
teckn9ne
Registered User
2010 KK Liberty 
 
Join Date: Jul 2011
Location: La Monte, Missouri
Posts: 166
Istayed stock tires and my dealer put mine in got 2".I call it a suspension upgrade not lift when speak about it every were but here LOL.My dealer said that they would still replace parts under the lifetime maxcare warranty even with OMEthey installed but sorry hear that ted some dealers sck....
__________________
2010 Jeep Liberty Sport 4X4 Natural Green Pearl
Silverstar Headlights,Mopar Hitch,Mopar Tow Hook,Mopar Skids,Mopar Locking Lugs,Mopar Remote Start,Factory Sirius Radio,WeatherTech Digital Floor Mats,JCROffroad Stage 3 Sliders,Hankook DynaPro RF10 LT225/75/16,Diehard Platinum P1,JBA 5.5 UCA,OME HD,
teckn9ne is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.