2010 Liberty won't start. Electricly dead - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2010 Liberty won't start. Electricly dead

RIGID LED Light Blowout Sale - All Sizes, All Series, all Truc-Lite LED Headlights! OCONEE OFF-ROAD 706-534-9955Jeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 07-29-2014, 06:10 AM   #1
seniorrip
Registered User
 
Join Date: Jul 2014
Location: Redford, MI
Posts: 3
2010 Liberty won't start. Electricly dead

2010 Liberty won't start. I Turned the key and everything turned off. It was as if there was no power at all. I popped the hood and heard a clicking from the start run solenoid in the fuse box. I swapped it out and still nothing. I jumped it and everything turned back on but still no crank. I get one click but no starter cranking.

seniorrip is offline   Reply With Quote Quick reply to this message
Unread 07-29-2014, 06:35 AM   #2
hvteng
Registered User
2006 TJ Wrangler 
 
Join Date: Aug 2013
Location: Sydney, Australia
Posts: 6
Hi, have you checked your battery?
hvteng is offline   Reply With Quote Quick reply to this message
Unread 07-29-2014, 06:49 AM   #3
seniorrip
Registered User
 
Join Date: Jul 2014
Location: Redford, MI
Posts: 3
I checked the connection and jumped it just in case. I had already driven it a half hour already this morning and just turned it off for 5 min when this problem happened.
seniorrip is offline   Reply With Quote Quick reply to this message
Unread 07-29-2014, 07:04 AM   #4
RENE65
Registered User
2008 KK Liberty 
 
Join Date: Dec 2011
Location: LAVAL, QUEBEC
Posts: 213
Still sounds like a dead battery , check the battery voltage when you try to crank before swaping everything. Always check the basics before getting into it deeper.
RENE65 is online now   Reply With Quote Quick reply to this message
Unread 07-29-2014, 07:57 AM   #5
seniorrip
Registered User
 
Join Date: Jul 2014
Location: Redford, MI
Posts: 3
It doesn't crank at all but I'll try replacing the battery.. Thanks guys
seniorrip is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.