2010 liberty in the shop - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > 2010 liberty in the shop

Currie Antirock, Currectlync & Lift Kits on Sale!Oconee Off-Road Free Shipping Lifts Tires Bumpers Tops andIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 04-15-2011, 10:39 AM   #1
capsfloyd
Registered User
2010 KK Liberty 
 
Join Date: May 2010
Location: Lancaster TX
Posts: 11
2010 liberty in the shop

None of the a/c controls are working/ fan as well . The headlights stay on when jeep is running, even in the auto pos. air will not blow in top or bottom?
Will see what the dealer says . She has about 19,000 miles on it.

capsfloyd is offline   Reply With Quote Quick reply to this message
Unread 04-15-2011, 11:30 AM   #2
sloan74
Registered User
2013 JK Wrangler 
 
Join Date: Apr 2010
Location: Charlotte NC
Posts: 606
Should be under bumper to bumper warranty still right? 3 years or 36k miles.

Sucks, that's weird. Sounds like a bad relay or switch. Prob a simple fix for them. Or course they will tell you the complete opposite....lol

That's how dealers roll.
sloan74 is offline   Reply With Quote Quick reply to this message
Unread 04-15-2011, 02:00 PM   #3
capsfloyd
Registered User
2010 KK Liberty 
 
Join Date: May 2010
Location: Lancaster TX
Posts: 11
Oh yea and we bought the ext. warranty. Its just getting the lil' bride out of her jeep to have it serviced .. It only has 16,000 miles on it.... my dodge ram cc 2009 has 95,000 and no trouble [yet] lol...
capsfloyd is offline   Reply With Quote Quick reply to this message
Unread 04-16-2011, 07:39 AM   #4
allskiing
Registered User
 
Join Date: Feb 2011
Location: laurel, ny
Posts: 34
Bummer....Sometimes things just break.
allskiing is offline   Reply With Quote Quick reply to this message
Unread 04-17-2011, 03:28 PM   #5
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Electronic "glithes" .... That frigging ECU is the culprit. The only " glitch' I have had is the ESP/BAS light came on while parked for about 5 minutes then went off.
__________________
2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.