2010 KK Renegade heat/ac problem - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 11-17-2012, 11:58 AM Thread Starter
Redredjeep
Registered User
2004 TJ Wrangler 
 
Join Date: Feb 2010
Location: Montrose
Posts: 68
2010 KK Renegade heat/ac problem

Blower has only one speed, will not cut off, a/c seems to work,recl. also (lights come on knobs). My system is the auto temp. control, turn that knob
no change, 3rd knob for vent,def.,heat, select...turn knob no change.
My findings point to blower resistor from other forums but can't find any parts for 2010 year mod.
I am trying to avoid the stealership, any ideas?

Redredjeep is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-18-2012, 05:47 AM
cke91082
Registered User
 
Join Date: Oct 2012
Location: Delaware
Posts: 24
Mine has the same problem. I took mine in though because it was still under warrantee....are you not?
cke91082 is offline  
post #3 of 4 Old 11-19-2012, 09:56 AM
lfhoward
Registered User
2008 KK Liberty 
 
Join Date: Nov 2012
Location: Morrisville
Posts: 931
Factorymoparparts.com has the 2010 blower motor resistor for $57. Search the catalog for the 2010 Libby under HVAC / Controls. It should be pretty easy to install yourself. I did this repair on my 2000 XJ back in the day and it's as simple as using a screwdriver and unclipping wiring harnesses. The resistor lives under the dash or behind the glovebox somewhere.

2008 Liberty Sport 4x4 Automatic
lfhoward is offline  
 
post #4 of 4 Old 11-21-2012, 06:51 PM Thread Starter
Redredjeep
Registered User
2004 TJ Wrangler 
 
Join Date: Feb 2010
Location: Montrose
Posts: 68
Quote:
Originally Posted by Redredjeep View Post
Blower has only one speed, will not cut off, a/c seems to work,recl. also (lights come on knobs). My system is the auto temp. control, turn that knob
no change, 3rd knob for vent,def.,heat, select...turn knob no change.
My findings point to blower resistor from other forums but can't find any parts for 2010 year mod.
I am trying to avoid the stealership, any ideas?
Problem fixed!!
Took it to the dealer, (still under warranty) found that it was a defective control unit, it had to be ordered and sent overnight to dealer. Was in & out in under 30 min.
(they replaced the panel w/ the 3 knobs)
1st time for any warranty work on this Jeep, and I didn't buy it from this dealer. No hassle, the way it should be.
Redredjeep is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome